User unknown

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

User unknown

Postby syscol » Mon Mar 19, 2007 4:32 pm

Hello,

I have setup a server with fedora and OpenEMM,

All is fine to sending emailing.

Now I want to use the bounce management, but I can't create an address that work. I have done several test and create 4 different Bounce-Filter and deleted the 3 first. Now the last I have have the address ext_4@bounce.mycompany.be.

When I send en email to this address, the server log the following error :
/var/log/maillog wrote:Mar 19 15:37:01 localhost sendmail[850]: l2JEb1rP000850: <ext_4@bounce.mycompany.be>... User unknown


If I send to an older address (deleted in OpenEMM) the log is :
/var/log/maillog wrote:Mar 19 15:37:01 localhost sendmail[850]: l2JEb1rP000850: Milter: to=<ext_3@bounce.syscol.be>, reject=550 5.1.1 No such user


Can someone help me to understand what is missing in my configuration.

For Info :
/home/openemm/var/spool/bav/bav.conf wrote:@localhost.localdomain accept:rid=local
ext_4@bounce.mycompany.be accept:rid=4,cid=1,fwd=syscol@xxxx.com
syscol
 
Posts: 4
Joined: Mon Mar 19, 2007 4:21 pm

Re: User unknown

Postby syscol » Wed Mar 28, 2007 12:00 pm

UP...

Someone can help me?

syscol wrote:Hello,

I have setup a server with fedora and OpenEMM,

All is fine to sending emailing.

Now I want to use the bounce management, but I can't create an address that work. I have done several test and create 4 different Bounce-Filter and deleted the 3 first. Now the last I have have the address ext_4@bounce.mycompany.be.

When I send en email to this address, the server log the following error :
/var/log/maillog wrote:Mar 19 15:37:01 localhost sendmail[850]: l2JEb1rP000850: <ext_4@bounce.mycompany.be>... User unknown


If I send to an older address (deleted in OpenEMM) the log is :
/var/log/maillog wrote:Mar 19 15:37:01 localhost sendmail[850]: l2JEb1rP000850: Milter: to=<ext_3@bounce.syscol.be>, reject=550 5.1.1 No such user


Can someone help me to understand what is missing in my configuration.

For Info :
/home/openemm/var/spool/bav/bav.conf wrote:@localhost.localdomain accept:rid=local
ext_4@bounce.mycompany.be accept:rid=4,cid=1,fwd=syscol@xxxx.com
syscol
 
Posts: 4
Joined: Mon Mar 19, 2007 4:21 pm

...

Postby christian.lang » Fri Jun 01, 2007 12:02 pm

I had the same problem - in my case it was due to a fault in the sendmail configuration.

You may check the following:
/etc/mail/mailertable
Is there a line
Code: Select all
bounce.yourcompany.com procmail:/home/openemm/conf/bav/bav.rc


/etc/mail/relaydomains
Is there a line
Code: Select all
bounce.yourcompany.com


AND - which was the problem in my case also check if the Bounce Domain is NOT listed in the /etc/mail/local-host-names File.

Hope this helps you a bit ...

best regards,

Christian
christian.lang
 
Posts: 30
Joined: Thu Apr 19, 2007 3:24 pm

User Unknown

Postby sailbert » Tue Oct 02, 2007 6:43 pm

I had a similar problem. Make sure the full computer name is not the same at the email domain name the mail is coming from.

I had my computer name set to bounce.domain.com

I was sending mail from ext_1@bounce.domain.com

Sendmail routed the mail as local since the domain matched. This bypasses the procmail filter. sendmail then returned an error Unknown User

I changed the email address I was sending mail from to ext_1@news.domain.com and also changed it in the database table company_tbl., /etc/mail/mailtertable, /etc/mail/relay-domains.
sailbert
 
Posts: 5
Joined: Fri Sep 21, 2007 7:54 pm
Location: coos bay, or


Return to Bounce Management

Who is online

Users browsing this forum: No registered users and 1 guest

cron