AttributeError: 'module' object has no attribute 'DBase'

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

AttributeError: 'module' object has no attribute 'DBase'

Postby philipp_m » Tue Mar 22, 2016 3:55 pm

Hi!

We used OpenEMM 2013 for a long time now and we thought it was time for an update to the newer 2015 version. I decided to set up the server on a fresh Ubuntu 14.04 installation running in a Virtual Host.

I followed all the Instructions in the Installation Guide and everything seemed to work until I tried to start OpenEMM itself..
Here is the console output:

root@Ubuntu-1404-trusty-64-minimal ~ # su - openemm
openemm@Ubuntu-1404-trusty-64-minimal:~$ openemm.sh start
Start /home/openemm/bin/scripts/bav-update.py .. done.
Start /home/openemm/bin/scripts/bav-trigger.py .. done.
Start /home/openemm/bin/scripts/bavd.py .. done.
Start /home/openemm/bin/bav -L INFO .. done.
Start python /home/openemm/bin/scripts/recovery.py .. done.
Start /home/openemm/bin/scripts/update.py account bounce .. done.
Start /home/openemm/bin/scripts/pickdist.py .. done.
CAUGHT EXCEPTION:
Traceback (most recent call last):
File "/home/openemm/bin/scripts/smenable.py", line 107, in <module>
main (sys.argv[0], sys.argv[1:])
File "/home/openemm/bin/scripts/smenable.py", line 87, in main
ctrl = SMCtrl ()
File "/home/openemm/bin/scripts/smenable.py", line 35, in __init__
self.db = agn.DBase ()
AttributeError: 'module' object has no attribute 'DBase'


Unable to determinate status for sendmail usages, assuming sendmail is enabled
Stopping obsolete sendmail processes: done.
Starting sendmails: listener * Starting Mail Transport Agent (MTA) sendmail * MTA is already running.
mail queues ADMIN QUEUE MIDQUEUE SLOWQUEUE done.
Start /home/openemm/bin/scripts/slrtscn.py .. done.
Starting up Tomcat ......
Check Java installation :OK
Check Tomcat installation :OK
Using CATALINA_BASE: /home/openemm
Using CATALINA_HOME: /opt/openemm/tomcat
Using CATALINA_TMPDIR: /home/openemm/temp
Using JRE_HOME: /opt/openemm/java
Using CLASSPATH: /opt/openemm/tomcat/bin/bootstrap.jar:/opt/openemm/tomcat/bin/tomcat-juli.jar
Tomcat started.

I am not able to connect to the Server - my browser says there is no connection to the site.

I found the following in the catalina.log:
22-Mar-2016 15:37:19.768 SEVERE [main] org.apache.tomcat.util.digester.Digester.startElement Begin event threw exception
java.lang.ClassNotFoundException: org.apache.catalina.core.JasperListener
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.apache.tomcat.util.digester.ObjectCreateRule.begin(ObjectCreateRule.java:116)
at org.apache.tomcat.util.digester.Digester.startElement(Digester.java:1178)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:509)
at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(AbstractXMLDocumentParser.java:182)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:1344)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2787)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:606)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:643)
at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1451)
at org.apache.catalina.startup.Catalina.load(Catalina.java:552)
at org.apache.catalina.startup.Catalina.load(Catalina.java:603)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:310)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:484)

22-Mar-2016 15:37:19.789 WARNING [main] org.apache.catalina.startup.Catalina.load Catalina.start using conf/server.xml: Error at (15, 66) : org.apache.catalina.core.JasperListener
22-Mar-2016 15:37:19.818 SEVERE [main] org.apache.tomcat.util.digester.Digester.startElement Begin event threw exception
java.lang.ClassNotFoundException: org.apache.catalina.core.JasperListener
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.apache.tomcat.util.digester.ObjectCreateRule.begin(ObjectCreateRule.java:116)
at org.apache.tomcat.util.digester.Digester.startElement(Digester.java:1178)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:509)
at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(AbstractXMLDocumentParser.java:182)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:1344)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2787)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:606)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:643)
at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1451)
at org.apache.catalina.startup.Catalina.load(Catalina.java:552)
at org.apache.catalina.startup.Catalina.start(Catalina.java:617)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:351)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:485)

22-Mar-2016 15:37:19.821 WARNING [main] org.apache.catalina.startup.Catalina.load Catalina.start using conf/server.xml: Error at (15, 66) : org.apache.catalina.core.JasperListener
22-Mar-2016 15:37:19.823 SEVERE [main] org.apache.catalina.startup.Catalina.start Cannot start server. Server instance is not configured.

I don't really have a clue what that means... Does anybody have an idea what could cause all these errors?

Thank you in advance!
Greets, Philipp
Last edited by philipp_m on Wed Aug 24, 2016 11:27 am, edited 1 time in total.
philipp_m
 
Posts: 7
Joined: Tue Mar 22, 2016 3:42 pm

Re: New OpenEMM 2015 Installation on Ubuntu 14.04

Postby philipp_m » Thu Aug 04, 2016 9:09 am

EDIT: If somebody has the same issue - I could find out that a python module was missing - fixed it by
Code: Select all
apt-get install python2.7-mysqldb

and commented out
Code: Select all
<!--Listener className="org.apache.catalina.core.JasperListener" /-->

in /home/openemm-2015/conf/server.xml because this doesn't work with Tomcat 8
philipp_m
 
Posts: 7
Joined: Tue Mar 22, 2016 3:42 pm


Return to Installation & Upgrades

Who is online

Users browsing this forum: No registered users and 2 guests

cron