Administration Tab links to blank page

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Administration Tab links to blank page

Postby philipp_m » Thu Aug 04, 2016 9:07 am

Hi all!

I installed OpenEMM 2015 from scratch on a ubuntu server. Everything seems to work well, without one thing:
When I click the administration Tab (in german "Verwaltung" - the last tab on the left side) I get a blank page and the URL is /useractivitylog.do;jsessionid=F79EE9583DBD3277ED4D44AFBFA47206?action=1

When I open the tab in my old Installation of OpenEMM 2013 I get to /profiledb.do;jsessionid=892EE908F4F222ECE625E7E354335B15?action=1

Does anybody have an idea?
Thanks!
philipp_m
 
Posts: 7
Joined: Tue Mar 22, 2016 3:42 pm

Re: Administration Tab links to blank page

Postby maschoff » Mon Aug 08, 2016 8:36 pm

When you click on the menu, what does the Tomcat log catalina.out show?
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2127
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Administration Tab links to blank page

Postby philipp_m » Tue Aug 09, 2016 9:00 am

Hi maschoff!

The /home/openemm-2015/logs/catalina.out has no new entry when I click on the menu... the only logfile that changes is the access log:
Code: Select all
"GET /useractivitylog.do;jsessionid=A2EEA532ADB7E27B5C442BB238500C2A?action=1 HTTP/1.1" 200 - "http://www.dekosternews.at/action.do;jsessionid=A2EEA532ADB7E27B5C442BB238500C2A?action=1"


What I found in the catalina.out is an IllegalArgumentException which seems to occur regularly (About 3-4 times a day, but no one is using the server):
Code: Select all
org.apache.coyote.http11.AbstractHttp11Processor process
INFO: Error parsing HTTP request header
Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
java.lang.IllegalArgumentException: Invalid character (CR or LF) found in method name
   at org.apache.coyote.http11.AbstractNioInputBuffer.parseRequestLine(AbstractNioInputBuffer.java:228)
   at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1009)
   at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:672)
   at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1500)
   at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1456)
   at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
   at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
   at java.lang.Thread.run(Thread.java:745)


Thanks!
philipp_m
 
Posts: 7
Joined: Tue Mar 22, 2016 3:42 pm

Re: Administration Tab links to blank page

Postby maschoff » Tue Aug 09, 2016 9:22 am

The IllegalArgumentException should not be related to the problem you described. Which version of Tomcat do you use?
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2127
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Administration Tab links to blank page

Postby philipp_m » Tue Aug 09, 2016 10:13 am

I guessed as much...

I'm running Tomcat Version 8.0.32 on Ubuntu 14.04.4 LTS
philipp_m
 
Posts: 7
Joined: Tue Mar 22, 2016 3:42 pm

Re: Administration Tab links to blank page

Postby philipp_m » Wed Aug 24, 2016 11:48 am

Hi!

I found a "solution" now. It seems that Since OpenEMM 2015 the Administration Tab is linked to the useractivitylog.do by default. I changed this in the file /home/openemm-2015/webapps/openemm/WEB-INF/classes/navigation/sidemenu.properties

There you can find the lines
Code: Select all
msg_7=Administration
token_7=settings.show
#Default changed for AGNEMM-2891
#href_7=/profiledb.do?action=1
href_7=/useractivitylog.do?action\=1

I changed these to
Code: Select all
msg_7=Administration
token_7=settings.show
#Default changed for AGNEMM-2891
href_7=/profiledb.do?action=1
#href_7=/useractivitylog.do?action\=1


Isn't the real solution, but worked for me.
philipp_m
 
Posts: 7
Joined: Tue Mar 22, 2016 3:42 pm


Return to Installation & Upgrades

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 2 guests

cron