Centos 7 problem entering the webconsole

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Centos 7 problem entering the webconsole

Postby KoenraadVanhoutte » Wed Jun 20, 2018 8:50 pm

Hi all, I try to install OpenEMM on a CentOS server together with postfix.
I have followed the installation procedures from the setup manual and I am able to start OpenEMM without an error message.

But when I try to login on the webconsole using http://comm.communication-vr7.fr:8080

I get following result :
First of all the address is immediately redirected to https://comm.communication-vr7.fr:8080
The page is showing following error message :

This site can’t provide a secure connection
comm.communication-vr7.fr sent an invalid response.
ERR_SSL_PROTOCOL_ERROR

Nothing else is running on the server, I have no Apache, nginx, ... or other webserver running.

I'm really stuck here.
I hope that someone knows how to solve this issue or can point me in the right direction.
Thank you very much,
Koenraad Vanhoutte
KoenraadVanhoutte
 
Posts: 4
Joined: Wed Jun 20, 2018 8:33 pm

Re: Centos 7 problem entering the webconsole

Postby maschoff » Sat Jun 23, 2018 8:33 pm

There seems to be a automatic forward from HTTP to HTTPS protocol on your system which you should disable.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2144
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Centos 7 problem entering the webconsole

Postby KoenraadVanhoutte » Tue Jun 26, 2018 5:15 pm

Hi maschoff, thanx for your reply.
The issue was twofold. There were errors in the ssl config which have now been corrected, as you already suggested.
I have installed a nginx reverse proxy which is working fine now.
The second part was the browser caching on my laptop that was completely messed up.
Clearing the cache together with a correct ssl config solved the issue.
KoenraadVanhoutte
 
Posts: 4
Joined: Wed Jun 20, 2018 8:33 pm

Re: Centos 7 problem entering the webconsole

Postby maschoff » Tue Jun 26, 2018 7:00 pm

Great, thanks for your feedback!
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2144
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany


Return to Installation & Upgrades

Who is online

Users browsing this forum: No registered users and 1 guest

cron