Newsletter does not send

Use this forum for all other questions regarding OpenEMM

Moderator: moderator

Newsletter does not send

Postby jinchuriki » Wed Feb 28, 2007 8:28 am

Hi guys,

I'm trying out OpenEMM but i couldn't get my newsletters to send.
I installed the application referring to the manual (altho i skipped the bounce mail part at this moment).

My system is :
Fedora Core 5
MySql 5
OpenEMM 5.0.2

I tested my sendmail installation using:
mail -s "Test sendmail" anon@pnc.com < /sample/content
I can receive the email from my mailbox (not the dummy email add supplied above :P)

I checked my /var/log/maillog and found the logs generated by OpenEMM:

....
Feb 28 14:55:47 machine xmlback[10939]: mail creation: 0;1;4;4;8;A;1;0;1;1;130668
Feb 28 14:58:12 machine xmlback[11029]: mail creation: 0;1;4;4;9;T;1;0;1;1;130667
Feb 28 14:58:16 machine xmlback[11033]: mail creation: 0;1;4;4;10;A;1;0;1;1;130668
Feb 28 14:59:49 machine xmlback[11071]: mail creation: 0;1;4;4;11;W;1;0;1;1;130658
Feb 28 14:59:50 machine xmlback[11072]: mail creation: 0;1;4;4;11;W;2;0;0;1;130231

I wonder what went wrong. I started sending 1 hour ago, but i have not received the emails yet. Where do i start to troubleshoot?

Thanks.

Regards,
J.
jinchuriki
 
Posts: 3
Joined: Wed Feb 28, 2007 8:21 am

Postby jinchuriki » Wed Feb 28, 2007 9:07 am

When i start the server, i get this:

Start /home/openemm/bin/scripts/bav-update.py .. done.
Start /home/openemm/bin/scripts/bav-trigger.py .. done.
Start /home/openemm/bin/scripts/bavd.py .. done.
Start /home/openemm/bin/bav -L INFO .. done.
Start /home/openemm/bin/scripts/update.py bounce account .. done.
Start /home/openemm/bin/scripts/pickdist.py .. done.
Stopping obsolete sendmail processes: done.
Starting sendmails: listener 550 Permission denied (real uid not trusted)
client queue Permission denied (real uid not trusted)
admin queue WARNING: Ignoring submission mode -N option (not in submission mode)
Permission denied (real uid not trusted)
mail queue WARNING: Ignoring submission mode -N option (not in submission mode)
Permission denied (real uid not trusted)
done.

Start /home/openemm/bin/scripts/slrtscn.py .. done.
Resin httpd start at Wed Feb 28 16:05:31 MYT 2007


Take note on the ones highlighted in red colour.
How can i fix that?

Thanks.
jinchuriki
 
Posts: 3
Joined: Wed Feb 28, 2007 8:21 am

Solved !!!

Postby jinchuriki » Wed Feb 28, 2007 9:57 am

I installed using this command rpm -ihv OpenEMM-5.0.2-1.i386.rpm.

Apparently i have to do these steps myself:
chown root:root bin/smctrl
chown root:root conf/bav/bav.rc
chmod 6755 bin/smctrl
chmod 0600 conf/bav/bav.rc

Issue solved. I can receive my newsletter now.
Thanks anyway guys.
jinchuriki
 
Posts: 3
Joined: Wed Feb 28, 2007 8:21 am

Re: Newsletter does not send

Postby Brian » Thu Nov 24, 2011 10:30 am

Thanks :D

As this save my life, i better leave a message with thanks.

My EMM worked after following
1) the 2011 install guide
2) Your last instructions for the permission.

Thanks.
Brian
 
Posts: 2
Joined: Thu Nov 24, 2011 10:27 am

Re: Newsletter does not send

Postby zohaa » Tue Sep 16, 2014 8:22 am

Can OpenEMM do one or both of the following?

1. A user subscribes to a mailing list on day 1. Can OpenEMM automatically send email A to that same user on day 2, then email B on day 8, email C on day 30, etc.?

2. A user subscribes to a mailing list on day 1. Can OpenEMM automatically add that user to a second mailing list on day 90, say? And/or automatically remove that user from the first list on day 120, say?

I've searched in the docs, forums, and wiki, but can't find the answers!

Thanks!
Pass your Pass4sure HP0-J67 in first try guaranteed using University College London study guide and Pass4sure 350-080 dumps questions.For more details visit now Facebook page and wikipedia best wishes.
zohaa
 
Posts: 1
Joined: Tue Sep 16, 2014 8:17 am


Return to Miscellaneous

Who is online

Users browsing this forum: No registered users and 3 guests

cron