C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Use this forum for all questions related to the source code of OpenEMM

Moderator: moderator

C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby barbaClemens » Wed Apr 20, 2016 1:55 pm

I have just updated my VS 2012 solution using/referencing the OpenEMM webserive with the new "OpenEMM Webserive API 2.0. When I try to use the method "ListSubscriberBinding(customerID)" I get the following exception:
Code: Select all
Unable to generate a temporary class (result=1).
error CS0030: Cannot convert type 'CRMM.OpenEMM.OpenEMM.Binding' to 'CRMM.OpenEMM.OpenEMM.ListSubscriberBindingResponse'
error CS0029: Cannot implicitly convert type 'CRMM.OpenEMM.OpenEMM.ListSubscriberBindingResponse' to 'CRMM.OpenEMM.OpenEMM.Binding'

Have anyone made a working request to the method "ListSubscriberBinding(customerID)" by using C#?
barbaClemens
 
Posts: 5
Joined: Wed Apr 20, 2016 1:08 pm

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby Ericc91 » Tue Jul 19, 2016 10:35 am

Hi barbaClemens,

I have the same problem, have you find a solution ?

Thanks
Eric
Ericc91
 
Posts: 2
Joined: Thu Jul 07, 2016 1:42 pm

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby barbaClemens » Tue Jul 19, 2016 10:52 am

Hi Eric,

Unfortunately I did not find any solution to this problem. I ended up doing a repository of my own to be able to retrieve data directly from the OpenEMM-database.

//barbaClemens
barbaClemens
 
Posts: 5
Joined: Wed Apr 20, 2016 1:08 pm

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby Ericc91 » Tue Jul 19, 2016 11:10 am

ok ! :-(

Anyway thank you for your reply

Eric
Ericc91
 
Posts: 2
Joined: Thu Jul 07, 2016 1:42 pm

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby maschoff » Wed Oct 12, 2016 10:42 am

Sorry, I could not reproduce this bug. I used for testing the PHP demo client WS_use_example.php with line
Code: Select all
var_dump ( $client->ListSubscriberBinding( ["customerID" => "815"] ));

for customer 815 and it worked just fine and the response was correct.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2131
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby barbaClemens » Wed Oct 12, 2016 11:06 am

maschoff wrote:Sorry, I could not reproduce this bug. I used for testing the PHP demo client WS_use_example.php with line
Code: Select all
var_dump ( $client->ListSubscriberBinding( ["customerID" => "815"] ));

for customer 815 and it worked just fine and the response was correct.


If I understand you correctly you have only tested this in PHP?

I have this problem in .NET and C#, I have not tried your webservice with PHP. Maybee there are some errors "created" in/by Visual Studio when I referencing the OpenEMM webservice and Visual Studio tries to generate classes for the referenced webservice?

I'm not sure exactly how this works in Visual Studio (or in PHP), I'm just thinking out loud :?
barbaClemens
 
Posts: 5
Joined: Wed Apr 20, 2016 1:08 pm

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby maschoff » Wed Oct 12, 2016 11:17 am

The developers have tested with Java, I just tested with PHP. Do you have a problem with webservices in general, or is only webservice ListSubscriberBinding affected?
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2131
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby barbaClemens » Wed Oct 12, 2016 11:29 am

For me it's only when I call "ListSubscriberBinding" that I recieve the error I have reported. I have not tested calling all methods in the webservice, but the other methods I'm using/calling seems to work just fine.
barbaClemens
 
Posts: 5
Joined: Wed Apr 20, 2016 1:08 pm

Re: C# and Webservice 2.0 - "ListSubscriberBinding" -> Error

Postby maschoff » Wed Oct 12, 2016 11:38 am

That is really strange, especially since the signature of the method is rather trivial. You could try with the PHP demo client (just the two files WSSESoapClient.php and WS_use_example.php) to make sure it is not a language-dependent problem. (You need packages php-pear and php-soap to get the client working.)
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2131
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany


Return to Development

Who is online

Users browsing this forum: No registered users and 0 guests

cron