OpenEMM + Postfix

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

OpenEMM + Postfix

Postby maschoff » Tue May 10, 2016 3:21 pm

The 2nd most wanted feature for OpenEMM is Postfix support. Well, with OpenEMM 2015 R3 we will finally deliver an OpenEMM version supporting Postfix. Anyone interested in helping us to optimize this version (i.e. configuration of Postfix), please comment here!

Download available at https://sourceforge.net/projects/openem ... velopment/

Install&Admin Guide 1.2 available at https://sourceforge.net/projects/openem ... rsions%29/
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: OpenEMM + Postfix

Postby maschoff » Tue May 17, 2016 9:25 pm

No feedback so far? Would be nice to hear from those of you who installed the R3 version, how everything works out so far!
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: OpenEMM + Postfix

Postby maschoff » Fri Jun 03, 2016 3:14 pm

If we do not get any negative feedback on the EA version, we consider it to work flawlessly and we will publish it as the official GA version of OpenEMM 2015 R3.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: OpenEMM + Postfix

Postby IzmirWayne » Tue Aug 09, 2016 1:48 pm

Hello.

I have issues with the R3 version.
I can not get Postfix to work with OEMM.
Somehow OEMM always wants to start sendmail even tough it is not installed.
When I try to run it it says "Can't open /etc/init.d/sendmail".
Also after this line "su - -c 'source bin/scripts/config.sh; echo $MTA' openemm" I get sendmail as output.
I made the Ubuntu VM new and did everything over again, I had the same issue.
I followed the steps, I just use localhost rather than a valid page, as the mails will be sent through another SMTP-Server.
It worked with Sendmail before, however on this VM Postfix won't work.

Can you help me with that?

Also I would recommend you to change something in the guide.
The guide says you have to run "alternatives --set mta /usr/sbin/sendmail.postfix", but "alternatives" is a Fedora command, you can't use it in Ubuntu.
However there is "update-alternatives" but it didn't work for me either, OEMM tried to start Postfix this time, but somehow it tells me the connection timed out, weird.
I use Ubuntu 16.04 LTS Server, so I have no GUI, wich makes things complicated, as there are simple GUI tools which would probably help, but I cannot use GUI on this one though.

I hope you can help me :)
Last edited by IzmirWayne on Tue Aug 09, 2016 1:57 pm, edited 1 time in total.
IzmirWayne
 
Posts: 2
Joined: Tue Aug 09, 2016 1:36 pm

Re: OpenEMM + Postfix

Postby maschoff » Tue Aug 09, 2016 1:56 pm

Ubuntu works with systemd since version 16.04, command line tool is systemctl. You should get familiar with systemctl. /etc/init.d does not really work any longer.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: OpenEMM + Postfix

Postby IzmirWayne » Tue Aug 09, 2016 2:07 pm

Thank you for your quick reply.
This is unfortunate, as I remember it working with 14.04 perfectly and my task is to use 16.04 :(
I will read through it, though I would be glad if you could help me with this, if you have any idea, how to set postfix as OEMM's MTA.
Unfortunately I have to use the most recent system, otherwise I would simply stay with 14.04.
IzmirWayne
 
Posts: 2
Joined: Tue Aug 09, 2016 1:36 pm

"bug" in config.sh with Ubuntu 16.04 was: OpenEMM + Postfix

Postby torcolato » Sat Aug 20, 2016 4:05 pm

Hi all.

The bin/scripts/config.sh script does not work under Ubuntu 16.04 (in conjunction with postfix).
It greps for postfix/master to detect if MTA=Postfix (line 124).
This fails with Ubuntu 16.04; changing the grep to postfix/sbin/master works.
Dunno it this changed with the latest Ubuntu release.

Cheers,
Christian
torcolato
 
Posts: 8
Joined: Thu Aug 24, 2006 2:12 pm

feature request for openemm.sh was: OpenEMM + Postfix

Postby torcolato » Sat Aug 20, 2016 4:15 pm

Hi All.

The openemm.sh script checks for the PID of the running tomcat instance with
JPS_RUNNING_PID=`ps -eo pid,command|grep org.apache.catalina|grep -v grep|awk '{print $1}'`

I suggest adding a 'grep openemm' or similar after the first grep otherwise it will report wrong results when other tomcat instances are running on the same server.
Which will result in error messages/wrong results when starting/stopping/status commands.

Cheers
Christian
torcolato
 
Posts: 8
Joined: Thu Aug 24, 2006 2:12 pm

Re: OpenEMM + Postfix

Postby maschoff » Wed Aug 24, 2016 9:44 am

Thanks for your feedback, we will take that in mind when creating the next version of OpenEMM!
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: OpenEMM + Postfix

Postby maschoff » Fri Oct 14, 2016 5:05 pm

The final release of OpenEMM 2015 R3 is now available at SourceForge: https://sourceforge.net/projects/openem ... MM%202015/

A big "Thanks" to all users who helped us with testing!
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany


Return to Bugs, bug fixes & releases

Who is online

Users browsing this forum: No registered users and 1 guest