OpenEMM Error Messages and Bounces

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

OpenEMM Error Messages and Bounces

Postby sjv » Wed Sep 12, 2007 3:38 pm

I am having problems getting bounces to work through bav. When I reply to a mailing, I get the following errors sent back to me:

----- The following addresses had permanent fatal errors -----
ext_1@bounce.host.ourcompany.com
(reason: Can't create output)
(expanded from: <openemm@host.ourcompany.com>)

----- Transcript of session follows -----
/home/openemm/bin/scripts/is_no_systemmail: /home/openemm/bin/scripts/is_no_systemmail: cannot execute binary file
/home/openemm/bin/scripts/scan_and_unsubscribe: /home/openemm/bin/scripts/scan_and_unsubscribe: cannot execute binary file
550 5.0.0 ext_1@bounce.host.ourcompany.com... Can't create output


I believe this is related to my bav problems. Does anyone have any suggestions?
sjv
 
Posts: 8
Joined: Wed Sep 12, 2007 3:22 pm

Postby sjv » Sat Sep 15, 2007 6:40 pm

more clues: I can run procmail from the command line and it works fine with bav.rc. This is all on Fedora 5

I added VERBOSE and now get the following:

procmail: [15278] Sat Sep 15 13:17:33 2007
procmail: Match on ! "(^(Mailing-List:|Precedence:.*(junk|bulk|list)|To: Multiple recipients of |(((Resent-)?(From|Sender)|X-Envelope-From):|>?From )([^>]*[^(.%@a-z0-9])?(Post(ma?(st(e?r)?|n)|office)|(send)?Mail(er)?|daemon|m(mdf|ajordomo)|n?uucp|LIST(SERV|proc)|NETSERV|o(wner|ps)|r(e(quest|sponse)|oot)|b(ounce|bs\.smtp)|echo|mirror|s(erv(ices?|er)|mtp(error)?|ystem)|A(dmin(istrator)?|MMGR|utoanswer))(([^).!:a-z0-9][-_a-z0-9]*)?[%@> ][^<)]*(\(.*\).*)?)?$([^>]|$)))"
procmail: Match on ! "(^(((Resent-)?(From|Sender)|X-Envelope-From):|>?From )([^>]*[^(.%@a-z0-9])?(Post(ma(st(er)?|n)|office)|(send)?Mail(er)?|daemon|mmdf|n?uucp|ops|r(esponse|oot)|(bbs\.)?smtp(error)?|s(erv(ices?|er)|ystem)|A(dmin(istrator)?|MMGR))(([^).!:a-z0-9][-_a-z0-9]*)?[%@> ][^<)]*(\(.*\).*)?)?$([^>]|$))"
procmail: Executing "/home/openemm/bin/scripts/is_no_systemmail"
/home/openemm/bin/scripts/is_no_systemmail: /home/openemm/bin/scripts/is_no_systemmail: cannot execute binary file
procmail: Non-zero exitcode (126) from "/home/openemm/bin/scripts/is_no_systemmail"
procmail: No match on "/home/openemm/bin/scripts/is_no_systemmail"
procmail: Executing "/home/openemm/bin/scripts/scan_and_unsubscribe"
/home/openemm/bin/scripts/scan_and_unsubscribe: /home/openemm/bin/scripts/scan_and_unsubscribe: cannot execute binary file
procmail: Non-zero exitcode (126) from "/home/openemm/bin/scripts/scan_and_unsubscribe"
procmail: Assigning "LASTFOLDER=/home/openemm/bin/scripts/scan_and_unsubscribe"


Does anyone have the bav filter working on Fedora?
sjv
 
Posts: 8
Joined: Wed Sep 12, 2007 3:22 pm

Postby sjv » Fri Sep 21, 2007 1:48 pm

Finally found the problem. The default for Fedora configures the SELinux policy for procmail so that it will not run the bav scripts as setup in the OpenEMM RPM package. You must disable SELinux or change the policy for procmail.
sjv
 
Posts: 8
Joined: Wed Sep 12, 2007 3:22 pm

SELinux

Postby maschoff » Fri Sep 21, 2007 8:42 pm

Thanks for the feedback! Did you disable SELinux or do you have changed the policy? If so, could you be so kind to post the policy (and probably save other Fedora users hours of work fiddling with the SELinux rules)?
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany


Return to Bounce Management

Who is online

Users browsing this forum: No registered users and 1 guest