Can't send test mail...

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

Can't send test mail...

Postby smartzip » Thu Mar 29, 2012 1:15 am

Hello,

I've deployed the OpenEMM 2011 software on two identical CentOS-based servers with MySQL (5.0.77), Apache-Tomcat (6.0.35), Sendmail (8.13.8) and JDK (1.6.0_18) on each server.
One server has no problem and everything works properly, but the second box has the messages (below) into the ~openemm/logs/catalina.out file when I'm trying to generate a "test mail". What is the problem? Please help!

--------------------
command [/home/openemm/bin/xmlback, -q, -l,
-E/home/openemm/temp/error3922186982606826147.tmp,
-ogenerate:temporary=true;syslog=false;account-logfile=/home/openemm/var/spool/log/account.log;bounce-logfile=log/extbounce.log;media=email;path=/home/openemm/var/spool/ADMIN,
/home/openemm/var/spool/META/AgnMail=D20120327114652=1=5=00001=liaMngA.xml]
returns 127
command [/home/openemm/bin/xmlback, -q, -l,
-E/home/openemm/temp/error3922186982606826147.tmp,
-ogenerate:temporary=true;syslog=false;account-logfile=/home/openemm/var/spool/log/account.log;bounce-logfile=log/extbounce.log;media=email;path=/home/openemm/var/spool/ADMIN,
/home/openemm/var/spool/META/AgnMail=D20120327114652=1=5=00001=liaMngA.xml]
failed (Missing binary? Wrong permissions?): java.lang.Exception:
command returns 127
triggerMailing: java.lang.Exception: Execution of
[/home/openemm/bin/xmlback, -q, -l,
-E/home/openemm/temp/error3922186982606826147.tmp,
-ogenerate:temporary=true;syslog=false;account-logfile=/home/openemm/var/spool/log/account.log;bounce-logfile=log/extbounce.log;media=email;path=/home/openemm/var/spool/ADMIN,
/home/openemm/var/spool/META/AgnMail=D20120327114652=1=5=00001=liaMngA.xml]
failed: java.lang.Exception: command returns 127
org.agnitas.backend.MailWriterMeta.startXMLBack(MailWriterMeta.java:261)
org.agnitas.backend.MailWriterMeta.done(MailWriterMeta.java:315)
org.agnitas.backend.MailgunImpl.doExecute(MailgunImpl.java:582)
org.agnitas.backend.MailgunImpl.executeMailgun(MailgunImpl.java:116)
org.agnitas.beans.impl.MailingImpl.triggerMailing(MailingImpl.java:594)
org.agnitas.web.MailingSendAction.sendMailing(MailingSendAction.java:601)
org.agnitas.web.MailingSendAction.execute(MailingSendAction.java:239)
org.apache.struts.chain.commands.servlet.ExecuteAction.execute(ExecuteAction.java:58)
org.apache.struts.chain.commands.AbstractExecuteAction.execute(AbstractExecuteAction.java:67)
org.apache.struts.chain.commands.ActionCommandBase.execute(ActionCommandBase.java:51)
org.apache.commons.chain.impl.ChainBase.execute(ChainBase.java:190)
org.apache.commons.chain.generic.LookupCommand.execute(LookupCommand.java:304)
org.apache.commons.chain.impl.ChainBase.execute(ChainBase.java:190)
org.apache.struts.chain.ComposableRequestProcessor.process(ComposableRequestProcessor.java:283)
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:449)
javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
--------------------

Thank you in advance,
--
# Serge Gordin
# Senior Systems Administrator
# SmartZip Analytics, Inc.
smartzip
 
Posts: 2
Joined: Wed Mar 28, 2012 10:49 pm

Re: Can't send test mail...

Postby maschoff » Thu Mar 29, 2012 8:10 pm

I think error suggestion "wrong permissions" is a good hint. Please untar the OpenEMM binary tarball with option -p and compare file permissions with your non-working installation.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2141
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Can't send test mail...

Postby smartzip » Fri Mar 30, 2012 1:28 am

Hello maschoff!

Thank you for your answer.

I've just checked - all files on both hosts, inside the ~openemm/bin directory, have permissions 755 except of two files (~/openemm/bin/scripts/*.pyc) which have 600.

Maybe this error is about some external binaries (python, java, etc), so is there any way to turn OpenEMM into a "debug" or "verbose" mode to trace the system calls? I can attach with the 'strace' utility to a process to get the info, but I have to know what binary is in charge of the issue to connect with.

Thank you very much.
--
# Serge Gordin
# Senior Systems Administrator
# SmartZip Analytics, Inc.
smartzip
 
Posts: 2
Joined: Wed Mar 28, 2012 10:49 pm


Return to Bugs, bug fixes & releases

Who is online

Users browsing this forum: No registered users and 1 guest

cron