Can't view emails with OpenEMM2013 for Windows

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

Can't view emails with OpenEMM2013 for Windows

Postby timr » Thu Jan 31, 2013 3:28 pm

I've been using OpenEMM 2011 on Windows Server 2003 with no problems. I upgraded to OpenEMM 2013, making sure I had all of the correct software and then applied the "update_openemm-2011-2013.sql" script located in USR_SHARE to the database. I'm able to login and do most things but am getting errors when I try to view a current email (from Mailings>Overview list) or create a new one. When I try to view a current email, I get this error.

"A general error occurred. Please check your input.
An error occurred
Cause: org.apache.jasper.JasperException: javax.servlet.ServletException: javax.servlet.jsp.JspException: ServletException in 'mailing/mailing-list.jsp': javax.servlet.jsp.JspTagException: You must specify one of the following: size"

When I try to create a new mailing, I get this error:

"An error occurred
Cause: javax.servlet.ServletException: org.springframework.dao.InvalidDataAccessResourceUsageException: could not execute query; nested exception is org.hibernate.exception.SQLGrammarException: could not execute query".

The strange thing is that if I also apply "openemm-2013.sql" to the database, it deletes all of my current data but I can create a new mailing and view old ones. Any ideas?
Last edited by timr on Wed Feb 13, 2013 2:50 pm, edited 1 time in total.
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013

Postby maschoff » Sat Feb 02, 2013 4:30 pm

Can you provide more error output from Tomcat's log file catalina.out?
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Can't view emails with OpenEMM2013

Postby timr » Mon Feb 04, 2013 2:51 pm

These are the errors listed in "catalina.2013-02-02" (located in OpenEMM\logs\tomcat).

1. SEVERE: Servlet.service() for servlet action threw exception
com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'mailing0_.openaction_id' in 'field list'

The above error happens when trying to create new mailing.

2. SEVERE: Servlet.service() for servlet jsp threw exception
javax.servlet.jsp.JspTagException: You must specify one of the following: size

The error above occurs when trying to view current mailing.
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013

Postby maschoff » Mon Feb 04, 2013 3:03 pm

I am not sure if your database was successfully updated to version 2013.
Code: Select all
mysql -u root -p
use openemm
desc mailing_tbl;

Does this return columns openaction_id and clickaction_id as the last two entries? If not, your database was not updated.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Can't view emails with OpenEMM2013

Postby timr » Mon Feb 04, 2013 4:24 pm

Columns openaction_id and clickaction_id are the last 2 columns listed in mailing_tbl after I applied "update_openemm-2011-2013.sql" to the database. After I received the View email and create new email errors, I applied "openemm-2013.sql" to see what would happen and the New mailing error disappeared but the script overwrote my data. When I then restore my data, the errors pop back up. I'm not a MySql expert buy it seems that if some statements were added to "openemm-2013.sql" to prevent data deletion, everything would work fine.

Thanks
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013

Postby timr » Tue Feb 12, 2013 3:20 pm

After working on this for a week, it looks like the Windows version of OpenEMM is only available as a new install and not an upgrade. If I upgrade OpenEMM 2011 to OpenEMM 2013 and apply the update_openemm-2011-2013.sql script located in USR_SHARE to the database, I can log in but not view any current mailings or create new ones. If I apply openemm-2013.sql to the data base, OpenEmm 2013 works great but all of my existing data (mailings,customers, etc.) is gone. I've looked at the openemm-2013.sql script and although it seems to have dump statements in it, it doesn't re-fill the tables after the DROP and CREATE Table statements. Has anyone been able to get Open 2013 Windows version to work after upgrading from 2011 as opposed to a new install?
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013

Postby maschoff » Tue Feb 12, 2013 5:32 pm

The online update does not work for the Windows version of OpenEMM, see README.txt:

If you use Windows, an online update is not possible. Please read the Windows Install Guide for information on how to install and update OpenEMM.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Can't view emails with OpenEMM2013

Postby timr » Tue Feb 12, 2013 6:18 pm

I'm aware of that and didn't use the online update. These are the steps I took.
Been using OpenEMM 2011 since shortly after it was released with no problems.

UPGRADE to 2013 Steps
1. Renamed current folder to OpenEMMOLD.
2. Downloaded OpenEMM 2013 for Windows.
3. Unzipped and copied folders to c:/OpenEMM
4. Applied update script update_openemm-2011-2013.sql (located in USR_SHARE) directly to MySQL database.
5. Logged into OpenEMM. All data (mailings, customer data, etc.) available but get error (documented in previous post) when trying to view email or create new email.
6. Not mentioned in Windows Install Guide but applied openemm-2013.sql directly to database since above was not working.
7. Logged into OpenEMM. All current data from OpenEMM 2011 gone, but can create, view and send test emails.

From looking at the openemm-2013.sql script, it looks like it has statements with LOCK and UNLOCK to reload current data:
-- Dumping data for table `admin_group_permission_tbl`

but after openemm-2013.sql is ran on the database, none of the current data is restored. If I then, restore a backup from OpenEMM 2011, problem #5 re-occurs. I don't know why restoring data would roll back changes put in by openemm-2013.sql but it seems like that OpenEMM 2013 can't read emails created by OpenEmm2011 and I did not have this problem when I upgraded from 6.2 to 2011.
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013

Postby maschoff » Tue Feb 12, 2013 6:43 pm

Everything until step 3 was fine. Please follow the Windows Install Guide (step 6 deleted you DB and recreated a new database from scratch).
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Can't view emails with OpenEMM2013

Postby timr » Wed Feb 13, 2013 2:49 pm

I followed the Windows Install Guide exactly and get the errors detailed in my previous post plus this error when I try to create a new mailing.

An error occurred
Cause: org.hibernate.HibernateException: A collection with cascade="all-delete-orphan" was no longer referenced by the owning entity instance: Mailing.dynTags

Something is missing from the "update_openemm-2011-2013.sql" script (script to update 2011 to 2013, per Windows install Guide). I realize that "openemm-2013.sql" (script for new installation) deletes the database and creates a new database but running "openemm-2013.sql" is the only way that I've been able to get OpenEMM 2013 to work. I've updated OpenEmm 6.0 to 6.2 and OpenEMM 6.2 to 2011 in the past with no problems so I'm fairly well-versed with the update process. I guess my next step will be to try to figure out what "openemm-2013.sql" contains that "update_openemm-2011-2013.sql" doesn't (besides the obvious DROP and CREATE Table statements). I'm running OpenEMM on a Windows 2003 Server.
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013 for Windows

Postby maschoff » Wed Feb 13, 2013 3:18 pm

I have a better idea: Download the Extension Development Guide from here
https://sourceforge.net/projects/openem ... velopment/
and have a look at appendix A which lists all OpenEMM tables and fields. Compare those to your database tables (use "DESC table_name;") to see if tables or fields are missing.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Can't view emails with OpenEMM2013 for Windows

Postby timr » Wed Feb 20, 2013 2:22 pm

I found the problem and everything is working now. It turns out that "dynamic_template" in mailing_tbl was set to NULL instead of Zero. Once I updated the mailing_tbl and set "dynamic_template" to 0, it works. Not sure how this happened because the update_openemm-2011-2013.sql script has a line to add this field and set it to 0. Had to restore a database backup after running "update_openemm-2011-2013.sql" and somehow, this restoration set "dynamic_template" back to NULL, which won't work. Then, when I ran "openemm-2013.sql", it set "dynamic_template" to 0 and everything worked but current data was lost. So, if you upgrade Windows version OpenEMM 2011 to OpenEMM 2013 and you get an error after running update_openemm-2011-2013.sql on the database, check to make sure that "dynamic_template" is set to 0 instead of NULL.
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm

Re: Can't view emails with OpenEMM2013 for Windows

Postby maschoff » Wed Feb 20, 2013 2:27 pm

Thanks for your feedback!
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2143
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany


Return to Bugs, bug fixes & releases

Who is online

Users browsing this forum: No registered users and 2 guests

cron