bug when sending mailing with multiple target group

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

bug when sending mailing with multiple target group

Postby bhcuong2008 » Fri Apr 11, 2014 4:06 pm

Hi,

I've faced issue with sending dynamic content (multiple content for multiple target group). The log output is below. I'm using OpenEMM 2013 R2, on Ubuntu 12.04 64bit. Everything is fine until I test dynamic content feature.

The output on GUI is "Error in dyn tags." The log from file 20140411-openemm-01-mailgun.log

===
[11.04.2014 15:03:44] ERROR/writer/meta/(1/8/76/-1): command [/home/openemm/bin/xmlback, -r, -q, -l, -E/home/openemm/temp/error1408408869775560055.tmp, -opreview:path=/home/openemm/temp/preview5650335494561699500.xml, /home/openemm/var/spool/META/AgnMail=D20140411150344=1=76=00001=liaMngA.xml.gz] returns 1:
[11.04.2014 15:03:44] 8891 ERROR/blockmail->dynamics->dynamic: Error in parsing:
( date_format(cust.SEND_DATE, '%Y%m%d') = date_format(date_sub(now(), interval 0 day), '%Y%m%d') AND cust.REGISTER_COUNT > 0)
Error description:
Syntax error hit.
( date_format(cust.SEND_DATE, '%Y%m%d') = date_format(date_sub(now(), interval 0 day), '%Y%m%d') AND cust.REGISTER_COUNT > 0)
*
Failed in parsing.

[11.04.2014 15:03:44] 8891 ERROR/blockmail->dynamics->dynamic: Unable to setup condition for DynID 277 in /home/openemm/var/spool/META/AgnMail=D20140411150344=1=76=00001=liaMngA.xml.gz
[11.04.2014 15:03:44] 8891 ERROR/blockmail->dynamics->dynamic: Unable to find valid element dyncont in /home/openemm/var/spool/META/AgnMail=D20140411150344=1=76=00001=liaMngA.xml.gz
[11.04.2014 15:03:44] 8891 ERROR/blockmail->dynamics: Unable to find valid element dynamic in /home/openemm/var/spool/META/AgnMail=D20140411150344=1=76=00001=liaMngA.xml.gz
[11.04.2014 15:03:44] 8891 ERROR/blockmail: Unable to find valid element dynamics in /home/openemm/var/spool/META/AgnMail=D20140411150344=1=76=00001=liaMngA.xml.gz

[11.04.2014 15:03:44] ERROR/writer/meta/(1/8/76/-1): command [/home/openemm/bin/xmlback, -r, -q, -l, -E/home/openemm/temp/error1408408869775560055.tmp, -opreview:path=/home/openemm/temp/preview5650335494561699500.xml, /home/openemm/var/spool/META/AgnMail=D20140411150344=1=76=00001=liaMngA.xml.gz] failed (Missing binary? Wrong permissions?): java.lang.Exception: command returns 1 (1181)
[11.04.2014 15:03:45] ERROR/writer/meta/(1/8/76/-1): command [/home/openemm/bin/xmlback, -r, -q, -l, -E/home/openemm/temp/error5440456575973078342.tmp, -opreview:path=/home/openemm/temp/preview4822611061111926102.xml, /home/openemm/var/spool/META/AgnMail=D20140411150345=1=76=00001=liaMngA.xml.gz] returns 1:
[11.04.2014 15:03:45] 8893 ERROR/blockmail->dynamics->dynamic: Error in parsing:
( date_format(cust.SEND_DATE, '%Y%m%d') = date_format(date_sub(now(), interval 0 day), '%Y%m%d') AND cust.REGISTER_COUNT > 0)
Error description:
Syntax error hit.
( date_format(cust.SEND_DATE, '%Y%m%d') = date_format(date_sub(now(), interval 0 day), '%Y%m%d') AND cust.REGISTER_COUNT > 0)
*
Failed in parsing.

[11.04.2014 15:03:45] 8893 ERROR/blockmail->dynamics->dynamic: Unable to setup condition for DynID 277 in /home/openemm/var/spool/META/AgnMail=D20140411150345=1=76=00001=liaMngA.xml.gz
[11.04.2014 15:03:45] 8893 ERROR/blockmail->dynamics->dynamic: Unable to find valid element dyncont in /home/openemm/var/spool/META/AgnMail=D20140411150345=1=76=00001=liaMngA.xml.gz
[11.04.2014 15:03:45] 8893 ERROR/blockmail->dynamics: Unable to find valid element dynamic in /home/openemm/var/spool/META/AgnMail=D20140411150345=1=76=00001=liaMngA.xml.gz
[11.04.2014 15:03:45] 8893 ERROR/blockmail: Unable to find valid element dynamics in /home/openemm/var/spool/META/AgnMail=D20140411150345=1=76=00001=liaMngA.xml.gz

[11.04.2014 15:03:45] ERROR/writer/meta/(1/8/76/-1): command [/home/openemm/bin/xmlback, -r, -q, -l, -E/home/openemm/temp/error5440456575973078342.tmp, -opreview:path=/home/openemm/temp/preview4822611061111926102.xml, /home/openemm/var/spool/META/AgnMail=D20140411150345=1=76=00001=liaMngA.xml.gz] failed (Missing binary? Wrong permissions?): java.lang.Exception: command returns 1 (1181)
===

I google alot but not finding solutions yet.

Please help.

Thank you.
bhcuong2008
 
Posts: 26
Joined: Fri Apr 11, 2014 3:56 pm

Re: bug when sending mailing with multiple target group

Postby bhcuong2008 » Fri Apr 11, 2014 4:17 pm

I think that the error is here
===
( date_format(cust.SEND_DATE, '%Y%m%d') = date_format(date_sub(now(), interval 0 day), '%Y%m%d') AND cust.REGISTER_COUNT > 0)
===

This is the condition in my target group. When using SEND_DATE equals to a specific date such as 20140411, it successes.

I dont know why. What's wrong with date_sub(now(). interval 0 day)?
bhcuong2008
 
Posts: 26
Joined: Fri Apr 11, 2014 3:56 pm

Re: bug when sending mailing with multiple target group

Postby bhcuong2008 » Fri Apr 11, 2014 4:28 pm

I try to replace date_sub(now(), interval 0 day) with now(), it's then ok. But with date_sub(now(), interval n day), where n could be 0, 1,.., then it's failed.
bhcuong2008
 
Posts: 26
Joined: Fri Apr 11, 2014 3:56 pm

Re: bug when sending mailing with multiple target group

Postby bhcuong2008 » Sat Apr 12, 2014 3:55 am

I've tested with OpenEMM 2013 virtual machine image provided at Sourceforge, and it's still failed with the same issue, when using condition date_sub or date_add as above.
bhcuong2008
 
Posts: 26
Joined: Fri Apr 11, 2014 3:56 pm

Re: bug when sending mailing with multiple target group

Postby bhcuong2008 » Fri Apr 25, 2014 4:34 pm

Hi maschoff,

Please give me your idea about this issue.

Thank you very much.
bhcuong2008
 
Posts: 26
Joined: Fri Apr 11, 2014 3:56 pm


Return to Bugs, bug fixes & releases

Who is online

Users browsing this forum: No registered users and 1 guest

cron