Openemm 2015 RC2 - Remote MySQL

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

Openemm 2015 RC2 - Remote MySQL

Postby rbustos » Tue Jan 20, 2015 7:43 pm

Is there any setup in order to use a remote MySQL with OpenEmm 2015 ?

Nothing on manuals, forums or configs files about for this version, I tried with classic setup by with no luck

Working in 2013 version:
Code: Select all
###############################################################################
# Database Connection Settings (dataAccessContxt.xml, etc.)
###############################################################################
jdbc.driverClassName=com.mysql.jdbc.Driver
jdbc.url=jdbc:mysql://10.10.10.10/openemm?useUnicode=yes&characterEncoding=UTF-8&useOldAliasMetadataBehavior=true&zeroDateTimeBehavior=convertToNull
jdbc.dialect=org.hibernate.dialect.MySQLDialect
jdbc.username=agnitas
jdb.password=openemm
jdbc.maxCount=30
jdbc.maxWait=10000



But in 2015 we have:
Code: Select all
###############################################################################
# Database Connection Settings (dataAccessContxt.xml, etc.)
###############################################################################
jdbc.openemmDB.jndiName=openemm_db
jdbc.openemmDB.dialect=org.hibernate.dialect.MySQLDialect
#jdbc.openemmDB.dialect=org.hibernate.dialect.Oracle9Dialect

jdbc.openemm_cmsDB.jndiName=openemm_cms_db
jdbc.openemm_cmsDB.dialect=org.hibernate.dialect.MySQLDialect


. Any advice will much appreciated.

--Rodrigo
rbustos
 
Posts: 1
Joined: Tue Jan 20, 2015 7:34 pm

Re: Openemm 2015 RC2 - Remote MySQL

Postby maschoff » Wed Jan 28, 2015 8:12 am

The details of the JNDI resources are defined in Tomcat's configuration file context.xml.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2130
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Openemm 2015 RC2 - Remote MySQL

Postby timr » Wed May 06, 2015 7:22 pm

I'm having the same problem with OpenEMM 2015 Windows version. I changed the two URL values in context.xml to the same value as in 2013-emm.properties and I still get "Failed to connect to database" when I run start.bat. Are there any other files that have to be changed to allow access to a remote MySQL installation with OpenEMM 2015?
timr
 
Posts: 33
Joined: Mon Aug 31, 2009 2:31 pm


Return to Bugs, bug fixes & releases

Who is online

Users browsing this forum: No registered users and 1 guest