Soap ListSubscriberBinding returns only one item

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

Soap ListSubscriberBinding returns only one item

Postby Yuna » Fri Nov 22, 2013 3:29 pm

I am using successfully the soap on openemm.
now i was swiching to the version number two "ws2" which is working fine except that i am getting only one result on the simple method "ListSubscriberBinding".
I was checking result of the database with the querry from the source code "select mailinglist_id, mediatype, user_type, user_status, change_date, exit_mailing_id, user_remark, creation_date from customer_1_binding_tbl where customer_id=323825" but there are more than one results.

so what could i do to get the list of bindings from the customer?
Yuna
 
Posts: 6
Joined: Mon Nov 04, 2013 11:55 am

Re: Soap ListSubscriberBinding returns only one item

Postby mdoerschmidt » Mon Nov 25, 2013 9:43 am

Hi Yuna,

I checked the webservice method ListSubscriberBindings. My recipient has 3 bindings on different mailing lists. Calling ListSubscriberBinding returns all 3 bindings.

Which version of OpenEMM do you use?


Best regards,

Markus
mdoerschmidt
 
Posts: 18
Joined: Fri Jan 04, 2013 8:55 am

Re: Soap ListSubscriberBinding returns only one item

Postby loru88 » Mon Jun 08, 2015 12:23 am

Hello
I have the same problem here, the ListSubscriberBinding method of the web services 2.0 return just one item, even if my recipient has 3 binding with different mailing lists.
I was working on OpenEMM 2013 in your vmx version, which has by default a mailinglist named "mailinglist" with ID 1.
It look like it return always this mailing list binding, because even when I bind a recipient to some new mailing list I create, the method return always just one item, the mailinglist "mailinglist" with ID 1
when I delete this mailinglist, the method return the next mailing list I created, but after one refresh page it return the mailinglist with ID 1 again
even if I delete it!

it did even with new recipients manually created

Someone else got this problem?
Please tell me a solution or if I wrong something



Lorenzo
loru88
 
Posts: 5
Joined: Fri Oct 17, 2014 10:26 am

Re: Soap ListSubscriberBinding returns only one item

Postby maschoff » Mon Jun 08, 2015 10:20 pm

To be able to reproduce the problem you mentioned it would be best to post the SOAP request and response here for analysis.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2129
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Soap ListSubscriberBinding returns only one item

Postby loru88 » Thu Jun 11, 2015 12:26 am

HI, sorry for the delay
in my case, I have a subscriber binded in more than one mailinglist, but the method ListSubscriberBindingRequest return just one mailing list, the one with the smallest ID.

the SOAP request is this: (i suppressed the header)
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://agnitas.org/ws/schemas">
    <SOAP-ENV:Header>
...
    </SOAP-ENV:Header>
    <SOAP-ENV:Body>
        <ns1:ListSubscriberBindingRequest>
            <ns1:customerID>5</ns1:customerID>
        </ns1:ListSubscriberBindingRequest>
    </SOAP-ENV:Body>
</SOAP-ENV:Envelope>



and the response is
Code: Select all
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
    <SOAP-ENV:Header />
    <SOAP-ENV:Body>
        <ns2:ListSubscriberBindingResponse xmlns:ns2="http://agnitas.org/ws/schemas">
            <ns2:item>
                <ns2:customerID>5</ns2:customerID>
                <ns2:mailinglistID>3</ns2:mailinglistID>
                <ns2:mediatype>0</ns2:mediatype>
                <ns2:status>1</ns2:status>
                <ns2:userType>W</ns2:userType>
                <ns2:remark>CSV File Upload</ns2:remark>
                <ns2:exitMailingID>0</ns2:exitMailingID>
                <ns2:changeDate>2014-11-27 17:22:42 CET</ns2:changeDate>
                <ns2:creationDate>2014-11-27 17:22:42 CET</ns2:creationDate>
            </ns2:item>
        </ns2:ListSubscriberBindingResponse>
    </SOAP-ENV:Body>
</SOAP-ENV:Envelope>



as you can see it seems everything fine, all others method works fine, just ListSubscriberBindingRequest is problably bugged
do you have any suggestion?
loru88
 
Posts: 5
Joined: Fri Oct 17, 2014 10:26 am

Re: Soap ListSubscriberBinding returns only one item

Postby maschoff » Thu Jun 11, 2015 7:54 am

Thanks, we will check it and provide a fix if this is a bug.
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2129
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Soap ListSubscriberBinding returns only one item

Postby mdoerschmidt » Thu Jun 11, 2015 1:21 pm

Hi Yuna,

there is a bug in webservice method ListSubscriberBinding of OpenEMM 2013. Please update to latest OpenEMM version.


Best regards,
Markus
mdoerschmidt
 
Posts: 18
Joined: Fri Jan 04, 2013 8:55 am

Re: Soap ListSubscriberBinding returns only one item

Postby loru88 » Thu Jun 11, 2015 2:40 pm

mdoerschmidt wrote:Hi Yuna,

there is a bug in webservice method ListSubscriberBinding of OpenEMM 2013. Please update to latest OpenEMM version.


Best regards,
Markus



Hi Markus, thanks for your support

I wouldn't like to upgrade to OpenEMM 2015 now, probably in the future,
Do you know if there is some patch to apply?
loru88
 
Posts: 5
Joined: Fri Oct 17, 2014 10:26 am


Return to Bugs, bug fixes & releases

Who is online

Users browsing this forum: Alexa [Bot] and 4 guests

cron