Cannot send mails via SMTP and Smart-relay

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

Cannot send mails via SMTP and Smart-relay

Postby ajda2 » Wed Sep 09, 2015 3:08 pm

Hello,
I have done everything steps by documentation:

- Turn off OpenEMM.
- Turn off SendMail /home/openemm/bin/sendmail-disable.sh
- Setup smart-relay in /home/openemm/conf to {username}:{password}@{smart-relay-domainname}
Except i have no domain name for actual testing sending. So instead domain name I have putted IP address of server
- In file /home/openemm/bin/scripts/semu.py I have deleted this two lines of code kódu: "smtp.starttls ()" a "smtp.ehlo ()"
- Turn On OpenEMM

In Log I have found this:

Code: Select all
[09.09.2015  12:19:54] 1024 INFO/block: Unpacking /home/openemm/var/spool/META/AgnMail=D20150909121951=1=16=0002=liaMngA.xml.gz
[09.09.2015  12:19:54] 1024 ERROR/block: Failed to execute mail creator "xmlback '-logenerate:account-logfile=var/spool/log/account.log;bounce-logfile=var/spool/log/extbounce.log;media=email;path=/home/openemm/var/spool/QUEUE' '/home/openemm/var/spool/META/AgnMail=D20150909121951=1=16=0002=liaMngA.xml.gz'" with 512
[09.09.2015  15:10:35] 1024 INFO/main: Going down
[09.09.2015  15:18:03] 6603 INFO/main: Starting up
[09.09.2015  15:18:19] 6603 INFO/main: Going down
[09.09.2015  15:18:39] 7380 INFO/main: Starting up
[09.09.2015  15:20:13] 7380 INFO/block: Unpacking /home/openemm/var/spool/META/AgnMail=D20150909151943=1=7=0001=liaMngA.xml.gz
[09.09.2015  15:20:13] 7380 ERROR/block: Failed to execute mail creator "xmlback '-logenerate:account-logfile=var/spool/log/account.log;bounce-logfile=var/spool/log/extbounce.log;media=email;path=/home/openemm/var/spool/QUEUE' '/home/openemm/var/spool/META/AgnMail=D20150909151943=1=7=0001=liaMngA.xml.gz'" with 512
[09.09.2015  15:20:13] 7380 INFO/block: Unpacking /home/openemm/var/spool/META/AgnMail=D20150909151943=1=7=0002=liaMngA.xml.gz
[09.09.2015  15:20:13] 7380 ERROR/block: Failed to execute mail creator "xmlback '-logenerate:account-logfile=var/spool/log/account.log;bounce-logfile=var/spool/log/extbounce.log;media=email;path=/home/openemm/var/spool/QUEUE' '/home/openemm/var/spool/META/AgnMail=D20150909151943=1=7=0002=liaMngA.xml.gz'" with 512


Please, can anybody help me
ajda2
 
Posts: 1
Joined: Wed Sep 09, 2015 2:22 pm

Re: Cannot send mails via SMTP and Smart-relay

Postby maschoff » Sat Sep 12, 2015 9:49 pm

I do not understand why you did this:
In file /home/openemm/bin/scripts/semu.py I have deleted this two lines of code kódu: "smtp.starttls ()" a "smtp.ehlo ()"
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2131
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany


Return to Using OpenEMM

Who is online

Users browsing this forum: No registered users and 2 guests

cron