Unsubscribe doesn't work

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

Unsubscribe doesn't work

Postby wrkilu » Fri Mar 24, 2017 10:45 pm

Hi,

I installed newest version of Openemm (v. 2015 R3). All works except unsubscribing setting. Whatever I tryied to set always I get "An error occured". Also I have to say that manual which I read isn't actual because on page 174 there is screenshot from creating new form and there is action set with value "Load user data" but in real application there isn't such otopn to choose! So how I could set it properly ?

Please help gurus ;)
wrkilu
 
Posts: 3
Joined: Fri Mar 24, 2017 10:39 pm

Re: Unsubscribe doesn't work

Postby maschoff » Sun Mar 26, 2017 6:26 am

The name of the required action is "load recipient data".
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2129
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Unsubscribe doesn't work

Postby wrkilu » Sun Mar 26, 2017 10:33 am

First thing is: I turned out what I did wrong and now unsubscribing works. I haven't read carefully manual (sorry) and I created just one form however its needed two. For next people: read carefully manual and in current version you must create:
- action "unsubscribe"
- two forms: "OptOutConfirm" and "UnsubscribeQuery"
Then this feature works.

Second thing regarding mistake in manual sorry Masschoff but I think still there is mistake because in real app there isn't action "Load recipint data". For proof I'm attaching screenshot with all options. Generally I chose "user_get_data" in this place and it works (to be clear).
Image

Moreover unfortunatelly I have another problem yet :(. Unsubscribing works but statistic of bounces not. Statistic of send emails yes but bounces not. I've send just 4 emails (one is fake), in /var/log/maillog there is bounce record but unfortunatelly Openemm stil shows bounces=0. Even I updated update.py script from bug fixes section download but still nothing. Can you help me Maschoff what it can be ?
wrkilu
 
Posts: 3
Joined: Fri Mar 24, 2017 10:39 pm

Re: Unsubscribe doesn't work

Postby maschoff » Sun Mar 26, 2017 1:36 pm

If there is no predefined user action in your account, you should create it yourself based on the EMM action "load recipient data".
OpenEMM Maintainer
maschoff
Site Admin
 
Posts: 2129
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany

Re: Unsubscribe doesn't work

Postby wrkilu » Wed Mar 29, 2017 8:06 am

And do you know maybe anything what can cause that bounces aren't counted at all ? (the last sentence in my previous post). Generally I tried to find myself root cause , I googled , looked here on forum but I couldn't find any idea what is wrong. I installed Openemm with Postfix.
wrkilu
 
Posts: 3
Joined: Fri Mar 24, 2017 10:39 pm


Return to Using OpenEMM

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron