Setup 2013 - JDK not found

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

binnen
Posts: 3
Joined: Fri Dec 05, 2008 10:57 am

Setup 2013 - JDK not found

Post by binnen » Wed Oct 09, 2013 11:26 am

Hello OpenEMM,

I have OpenEMM 2013 installed on a Windows 2008 R2 server with Tomcat 6 en JDK 7. After running the setup.bat i'll keep getting the messsage of JDK not found. JAVA_HOME=C:\Program Files\Java\jdk1.7.0_25 and in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\CurrentVersion Data 1.7
I've tried it with JDK 1.6.045 with the same result.
What can i do to fix this?

Regards,
Johan

binnen
Posts: 3
Joined: Fri Dec 05, 2008 10:57 am

Re: Setup 2013 - JDK not found

Post by binnen » Thu Oct 17, 2013 1:55 pm

Hello OpenEMM,

I found the source of my problem. The python function agn.winregFind returns "None" and can not find the location of r'SOFTWARE\JavaSoft\Java Development Kit' in this function call : agn.winregFind (jdkkey, 'CurrentVersion'). agn.py is loaded because it return the path of agn.pythonpath
Is this a bug and is there a workaround?

Regards,
Johan

maschoff
Site Admin
Posts: 2146
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Setup 2013 - JDK not found

Post by maschoff » Thu Oct 17, 2013 6:32 pm

OpenEMM was developed on Linux and the Win32 version was created on Windows XP. No other Windows version was ever tested by the original developers.
OpenEMM Maintainer

Post Reply