Some troubles of bounce management

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

decios
Posts: 2
Joined: Mon Dec 05, 2011 5:05 pm

Some troubles of bounce management

Post by decios » Mon Dec 05, 2011 5:36 pm

Hy,
I've installed openemm 2011, and it's ok...the instant bounce work perfectly,
but I'll try to configure bounce delayed and It don't work.
This is my scenario:
- DNS configuration
mydomain.com A xxx.xxx.xxx.xxx
host.mydomain.com A xxx.xxx.xxx.xxx
news.mydomain.com A xxx.xxx.xxx.xxx
news.mydomain.com MX 10 host.mydomain.com

* records A have the same address

- Sendmail Configuration:

root@host:/# cat /etc/mail/mailertable
news.mydomain.com procmail:/home/openemm/conf/bav/bav.rc

root@host:/# cat /etc/mail/relay-domains
mydomain.com
news.mydomain.com

In "/etc/mail/sendmail.mc" I've added following lines:
FEATURE(`mailertable', `hash -o /etc/mail/mailertable.db')dnl
MAILER(`procmail')dnl
INPUT_MAIL_FILTER(`bav',`S=unix:/home/openemm/var/run/bav.sock, F=T')dnl

- OpenEMM Configuration


root@host:/# cat /home/openemm/conf/bav/bav.conf-local
news@news.mydomain.com alias:ext_1@news.mydomain.com
news@news.mydomain.com alias:ext_2@news.mydomain.com

root@host:/# cat /home/openemm-2011/var/spool/bav/bav.conf
@localhost accept:rid=local
@host.mydomain.com accept:rid=local
@host.mydomain.com accept:rid=local
ext_1@news.mydomain.com accept:rid=1,cid=1,fwd=real_address@hotmail.it
ext_2@news.mydomain.com accept:rid=2,cid=1,fwd=real_address@hotmail.it
news@news.mydomain.com alias:ext_1@news.mydomain.com
news@news.mydomain.com alias:ext_2@news.mydomain.com

In the web-interface I've created 2 bounce filter.
If I send a private mail to news@news.mydomain.com, it work right, and milter forward this mail to real_address@hotmail.it.
But when I send a mailing (with incorrett address)...don't send anything...
This is maillog after send mailing:
Dec 5 16:36:10 host sendmail[20773]: STARTTLS=client, relay=mail.xxx.it., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Dec 5 16:36:10 host sendmail[20773]: 00001600000000009: to=<errore@xxx.it>, delay=00:00:29, xdelay=00:00:01, mailer=esmtp, pri=0, relay=mail.xxx.it. [10.40.0.19], dsn=2.0.0, stat=Sent (Ok: queued as AD65372BFF)
Dec 5 16:36:10 host sendmail[20773]: 00001600000000004: to=<user1@xxx.it>, delay=00:00:29, xdelay=00:00:00, mailer=esmtp, pri=0, relay=mail.xxx.it. [10.40.0.19], dsn=2.0.0, stat=Sent (Ok: queued as CCFE472D48)
Dec 5 16:36:10 host sendmail[20773]: 00001600000000003: to=<user2@yyy.it>, delay=00:00:29, xdelay=00:00:00, mailer=esmtp, pri=0, relay=mail.yyy.it. [10.40.0.6], dsn=2.0.0, stat=Sent (message sent ok)
Dec 5 16:36:10 host sendmail[20773]: STARTTLS=client, relay=mail.jjj.it., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Dec 5 16:36:10 host sendmail[20773]: 00001600000000008: to=<full@jjj.it>, delay=00:00:29, xdelay=00:00:00, mailer=esmtp, pri=0, relay=mail.impresa21.it. [10.40.0.19], dsn=2.0.0, stat=Sent (Ok: queued as 135C072D56)
* where errore@xxx.it and full@jjj.it would be bounced
How you can see, don't appear Milter messages...

I'm going crazy with Bounce configuration...can you help me please????

decios
Posts: 2
Joined: Mon Dec 05, 2011 5:05 pm

Re: Some troubles of bounce management

Post by decios » Tue Dec 06, 2011 2:44 pm

Coming back non my trouble,
if I send a mail from an external account to news@news.mydomain.com, bav.rc (and, of course, Milter) work perfectly....
this is the log:

Dec 6 14:35:02 host sm-mta[28301]: pB6DZ199028301: from=<mymail@xxx.it>, size=1124, class=0, nrcpts=1, msgid=<4EDE19ED.7070605@xxx.it>, bodytype=7BIT, proto=ESMTP, daemon=MTA-v4, relay=mail.xxx.it [10.40.0.19]
Dec 6 14:35:02 host sm-mta[28301]: pB6DZ199028301: Milter add: header: X-AGNMailloop: from=<<mymail@xxx.it>,rid=2,cid=1,fwd=real_address@hotmail.it,to=<news@news.mydomain.com>
Dec 6 14:35:02 host sm-mta[28301]: pB6DZ199028301: Milter add: header: X-AGNLoop: set
Dec 6 14:35:02 host sendmail[28311]: pB6DZ2iT028311: from=openemm, size=1391, class=0, nrcpts=1, msgid=<4EDE19ED.7070605@xxx.it>, relay=openemm@localhost
Dec 6 14:35:03 host sm-mta[28312]: pB6DZ2KN028312: from=<openemm@host.mydomain.com>, size=1517, class=0, nrcpts=1, msgid=<4EDE19ED.7070605@xxx.it>, proto=ESMTP, daemon=MTA-v4, relay=localhost [127.0.0.1]
Dec 6 14:35:03 host sendmail[28311]: pB6DZ2iT028311: to=real_address@hotmail.it, ctladdr=openemm (1001/1001), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=31391, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (pB6DZ2KN028312 Message accepted for delivery)
Dec 6 14:35:03 host sm-mta[28304]: pB6DZ199028301: to=<news@news.mydomain.com>, delay=00:00:01, xdelay=00:00:01, mailer=procmail, pri=121124, relay=/home/openemm/conf/bav/bav.rc, dsn=2.0.0, stat=Sent
Dec 6 14:35:05 host sm-mta[28315]: pB6DZ2KN028312: to=<real_address@hotmail.it>, ctladdr=<openemm@host.mydomain.com> (1001/1001), delay=00:00:03, xdelay=00:00:02, mailer=esmtp, pri=121517, relay=mx3.hotmail.com. [65.55.92.184], dsn=2.0.0, stat=Sent ( <4EDE19ED.7070605@xxx.it> Queued mail for delivery)

Why it doesn't work, when I send a mailing to over quota box???

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Re: Some troubles of bounce management

Post by ud » Thu Dec 08, 2011 9:38 am

Your configuration seems to work as designed. Depending on the received message the rules (as defined in bav.rule) do not match so the mail is forwarded. The rules are very limited to avoid losing mails and, on the other hand, accepts also mails, which are not recognized as bounce message. Be free to extend your bav.rule file to satisfy your requirements.

-- ud

Post Reply