No bounces using Smart Host

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

avenitsh
Posts: 3
Joined: Mon Jan 19, 2009 4:39 am

No bounces using Smart Host

Post by avenitsh » Sat Jan 07, 2012 6:49 am

Hi and happy new year!

We have successfully installed OpenEMM 2011 and we are able to send out mailings using our company's e-mail server as smart host. When we disable the Smart Host and let EMM send by the local Sendmail, everything works fine - Just when using the smart host, no bounces can be received.

Here is our setup:

OpenEMM 2011 Server:

- CentOS 5.7 x64
- Using Sendmail with smart host mail.company.com
- DNS Setup according to manual (This setup has been tested and works):

host.our-emmserver.com A 1.2.3.4
news.our-emmserver.com A 1.2.3.4
news.our-emmserver.com MX host.our-emmserver.com.

We did all the changes to /etc/mail/sendmail.mc as described in the manual Chapter 10, Firewall setup also works.
In addition, we configured /home/openemm/conf/bav/bav.conf-local to be news@news.our-emmserver.com alias:ext_1@news.our-emmserver.com. We have added a bounce filter in EMM for ext_1

In order to debug this, we did some command line testing on the EMM Server:

Code: Select all

echo "This is a test" | sendmail -fnews@news.our-emmserver.com foo@bar.invalid
On our company's mail server (running PostFix), this will create the following log:

Code: Select all

Jan  7 06:17:41 mail postfix/cleanup[5156]: 03062156CC28: message-id=<201201070517.q075HVfT010764@www3.our-company.com>
Jan  7 06:17:41 mail postfix/qmgr[3367]: 03062156CC28: from=<news@news.our-emmserver.com>, size=750, nrcpt=1 (queue active)
Jan  7 06:17:42 mail postfix/smtp[5157]: 03062156CC28: to=<foo@bar.invalid>, relay=none, delay=1.4, delays=1.3/0.01/0.11/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=bar.invalid type=A: Host not found)
Jan  7 06:17:42 mail postfix/bounce[5159]: 03062156CC28: sender non-delivery notification: 16E22156CC2A
Jan  7 06:17:42 mail postfix/qmgr[3367]: 03062156CC28: removed
As you can see from the last line, a "sender non-delivery notification" is being sent back to the EMM Server (and we can receive it)

However, when sending a mailing from EMM, the log is a little different:

Code: Select all

Jan  7 05:18:14 mail postfix/cleanup[4077]: F3FCD156CC28: message-id=<20120107121736-1.1.c.7.0.97lfw7777k@openemm.invalid>
Jan  7 05:18:14 mail postfix/qmgr[3367]: F3FCD156CC28: from=<news@news.our-emmserver.com>, size=2071, nrcpt=1 (queue active)
Jan  7 05:18:14 mail postfix/smtp[4078]: F3FCD156CC28: to=<foo@bar.invalid>, relay=none, delay=1.3, delays=1.3/0/0.02/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=bar.invalid type=A: Host not found)
Jan  7 05:18:14 mail postfix/qmgr[3367]: F3FCD156CC28: removed
Note the "non-delivery notification" is missing here.

In order to investigate why our manually sent e-mails will trigger a non-delivery notification and EMM does not, we had a look at the EMM Server's sendmail logs:

When sending by command line (relevant parts only):

Code: Select all

Jan  7 13:17:34 www3 sendmail[10764]: q075HVfT010764: to=foo@bar.invalid, ctladdr=news@news.our-emmserver.com (0/0), delay=00:00:03, xdelay=00:00:01, mailer=relay, pri=30015, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (q075HX8e010765 Message accepted for delivery)
Note the part ctladdr=news@news.our-emmserver.com

When sending by EMM:

Code: Select all

Jan  7 12:18:15 www3 sendmail[10500]: 2900T1f1d00000003: to=<foo@bar.invalid>, delay=00:00:39, xdelay=00:00:04, mailer=relay, pri=0, relay=mail.our-company.com. [xxx.xxx.xxx.xxx], dsn=2.0.0, stat=Sent (Ok: queued as F3FCD156CC28)
There is no ctladdr set, which we think is the cause for the Smart Host not sending back any non-delivery notification.

Question is: Could this be the reason why the bounce management doesn't work?

Thank you a lot for your time and efforts!