No "Filter address" field on "New bounce filter" form

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

spanish
Posts: 1
Joined: Tue Nov 22, 2011 4:23 pm

No "Filter address" field on "New bounce filter" form

Post by spanish » Tue Nov 29, 2011 2:40 pm

Hello,

I can't view the "Filter address" field, in the "New bounce filter" form.

I only see these fields:

---------------------------------------------------
OpenEMM 2011 -> Administration -> Bounce-Filters -> New bounce filter

Name:
Description (optional):

Forward incoming emails
Address:

Use for subscribe address
Mailing list:
Form for double-opt-in mail:

Autoresponder
Sender address:
Subject:
Text version:
HTML version:
---------------------------------------------------

Is this normal? I need create the "Filter address"?

Thanks!

Manuel

maschoff
Site Admin
Posts: 2146
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: No "Filter address" field on "New bounce filter" form

Post by maschoff » Sat Dec 03, 2011 6:43 pm

The address (like "ext_1@news.openemm.org") will be automatically generated if you create a new filter.
OpenEMM Maintainer

jabernethy
Posts: 5
Joined: Wed May 13, 2009 5:05 pm
Contact:

Re: No "Filter address" field on "New bounce filter" form

Post by jabernethy » Tue Jan 17, 2012 10:46 pm

I noticed the same issue as the poster above described. However, when I create a bounce filter, the generated email shows up as "ext_1@". The sender hostname is missing. I have set up the DNS A and MX records as described, but there is no other mention of configuring the sender hostname in OpenEMM. How do I get the New Bounce Filter to use my sender hostname?

maschoff
Site Admin
Posts: 2146
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: No "Filter address" field on "New bounce filter" form

Post by maschoff » Wed Jan 18, 2012 3:02 pm

See install guide, section 9.2.
OpenEMM Maintainer

jabernethy
Posts: 5
Joined: Wed May 13, 2009 5:05 pm
Contact:

Re: No "Filter address" field on "New bounce filter" form

Post by jabernethy » Wed Jan 18, 2012 6:55 pm

I've been through section 9.2 of the Installation manual several times and I'm still trying to understand it. The manual describes updating the DNS with the various hosts and MX records and so forth. And I've done that. But I don't see any discussion of how OpenEMM knows which domain should be used for the filter address. Where should this be configured in OpenEMM?

maschoff
Site Admin
Posts: 2146
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: No "Filter address" field on "New bounce filter" form

Post by maschoff » Thu Jan 19, 2012 4:00 pm

A quote from the install guide (section 6.2 A) which should help:
If you plan to use the bounce management for asynchronous bounces, replace the empty mailloop string '' directly after the redirection URL you just entered in the step before, with the sender hostname (see section 8.2).
OpenEMM Maintainer

jabernethy
Posts: 5
Joined: Wed May 13, 2009 5:05 pm
Contact:

Re: No "Filter address" field on "New bounce filter" form

Post by jabernethy » Thu Jan 19, 2012 10:09 pm

Found the configuration in the openemm-2011.sql file and set the sender domain. The bounce filter is created with the proper domain.

Now I'm having a different issue: sendmail is posting milter error messages in the maillog file:
Jan 19 14:40:51 localhost sendmail[31159]: q0JKep3Q031159: Milter (bav): error connecting to filter: Permission denied
Jan 19 14:40:51 localhost sendmail[31159]: q0JKep3Q031159: Milter (bav): to error state
Jan 19 14:40:51 localhost sendmail[31159]: q0JKep3Q031159: Milter: initialization failed, temp failing commands

I have the following line in my sendmail.mc file:
INPUT_MAIL_FILTER(`bav', `S=unix:/home/openemm/var/run/bav.sock, F=T')dnl

And here are the permissions on the bav.sock Unix domain socket:
srwxrwxr-x. 1 openemm openemm 0 Jan 19 14:27 bav.sock

Changing permission on bav.sock to o+w doesn't seem to help and is wiped out when I stop and restart OpenEMM anyway. All of the bav-related processes seem to be running under the openemm user. Sendmail is running as root or smmsp.

duke
Posts: 8
Joined: Tue Nov 27, 2007 4:35 pm

Re: No "Filter address" field on "New bounce filter" form

Post by duke » Wed Jan 25, 2012 3:12 pm

jabernethy wrote:Found the configuration in the openemm-2011.sql file and set the sender domain. The bounce filter is created with the proper domain.

Now I'm having a different issue: sendmail is posting milter error messages in the maillog file:
Jan 19 14:40:51 localhost sendmail[31159]: q0JKep3Q031159: Milter (bav): error connecting to filter: Permission denied
Jan 19 14:40:51 localhost sendmail[31159]: q0JKep3Q031159: Milter (bav): to error state
Jan 19 14:40:51 localhost sendmail[31159]: q0JKep3Q031159: Milter: initialization failed, temp failing commands
I had the same problem with OpenEMM 2011 on CentOS 6.2. Turns out it was selinux-related, so I simply disabled selinux completely. Now everythings works fine again.

Kind Regards,
Michael

Post Reply