Complete Mails are not sent and remain in "queue"

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

iam4urk
Posts: 10
Joined: Sun Apr 15, 2012 4:10 pm

Complete Mails are not sent and remain in "queue"

Post by iam4urk » Mon May 20, 2013 7:28 pm

Hi,

I have recently update openemm from 2011 to 2013 on centos6.2 server 32 bit. After the update we are having some issues.

1. While starting or restarting openemm i get the error

Code: Select all

[openemm@host ~]$ openemm.sh restart
bash: openemm.sh: command not found
2. When i schedule 5000 mails to send only 2000 mails are sent and rest of then are not sent and remain in openemm "QUEUE" directory.

while restarting openemm i get the below error

Code: Select all

[openemm@host bin]$ ./openemm.sh restart
Shutting down Tomcat ......
Using CATALINA_BASE:   /home/openemm
Using CATALINA_HOME:   /opt/openemm/tomcat
Using CATALINA_TMPDIR: /home/openemm/temp
Using JRE_HOME:        /opt/openemm/java
Using CLASSPATH:       /opt/openemm/tomcat/bin/bootstrap.jar
Waiting for shutdown of Tomcat:.
Stop scripts/slrtscn.py program  .. done.
Stop /home/openemm/bin/qctrl program with signal 15 .. done.
Stop all sendmail processes:  Shutting down sm-client:     [  OK  ]
Shutting down sendmail:                                    [  OK  ]
 -15:13779 -15:13785 -15:13792 -15:13799 -15:13806 -15:13808 -15:13813 -15:13820 -15:14007 -15:14033 -15:14054 -15:14117 -15:14133 -15:14144 -15:14145 -15:14159 -15:14160 -15:14167 -15:14243 -15:14244 -15:14253Shutting [FAILED]dmail: 
Starting sendmail:                                         [  OK  ]
Starting sm-client:                                        [  OK  ]
 done.
Stop scripts/pickdist program  .. done.
Stop scripts/update.py program  .. done.
Stop bin/bav program with signal 15 .. done.
Stop bin/bav program with signal 9 .. done.
Stop scripts/bavd program  .. done.
Stop scripts/bav-trigger program with signal 15 .. done.
Stop scripts/bav-update program with signal 15 .. done.
Start /home/openemm/bin/scripts/bav-update.py .. done.
Start /home/openemm/bin/scripts/bav-trigger.py .. done.
Start /home/openemm/bin/scripts/bavd.py .. done.
Start /home/openemm/bin/bav -L INFO .. done.
Start python /home/openemm/bin/scripts/recovery.py .. done.
Start /home/openemm/bin/scripts/update.py account bounce .. done.
Start /home/openemm/bin/scripts/pickdist.py .. done.
Stopping obsolete sendmail processes:   -15:14445 -15:14453 done.
Starting sendmails:   listener Starting sendmail:          [  OK  ]
 mail queues  ADMIN  QUEUE  MIDQUEUE  SLOWQUEUE  done.
Start /home/openemm/bin/scripts/slrtscn.py .. done.
Starting up Tomcat ......
Check Java installation          :OK
Check Tomcat installation        :OK
Using CATALINA_BASE:   /home/openemm
Using CATALINA_HOME:   /opt/openemm/tomcat
Using CATALINA_TMPDIR: /home/openemm/temp
Using JRE_HOME:        /opt/openemm/java
Using CLASSPATH:       /opt/openemm/tomcat/bin/bootstrap.jar
[root@host ~]#/etc/init.d/sendmail status
sendmail (pid  15012) is running...
sm-client dead but pid file exists
[root@host ~]#/etc/init.d/sendmail restart
Shutting down sm-client:                                   [  OK  ]
Shutting down sendmail:                                    [  OK  ]
Starting sendmail:                                         [  OK  ]
Starting sm-client:                                        [  OK  ]

Thanks in Advance for the suggestions

maschoff
Site Admin
Posts: 2146
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Complete Mails are not sent and remain in "queue"

Post by maschoff » Tue May 21, 2013 9:25 pm

1. If your shell can not find openemm.sh something must be wrong with your config, because this file is locacted in ~/bin and this directory should automatically added to your path (via .bash_profile).

2. What is the error?
OpenEMM Maintainer

Post Reply