Mailing was converted to template!

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

nick
Posts: 7
Joined: Tue Feb 16, 2010 12:56 am

Mailing was converted to template!

Post by nick » Thu Mar 18, 2010 6:16 am

Hello!

A very strange thing just happened with my OpenEMM.

I was trying to move a mailing (that was still in progress) into a campaign. (I had sent a number of mailings previously that *should* have been part of the same campaign, but I hadn't set up any campaigns yet.)

I edited the mailing, and selected my new campaign in the pull-down. Then I realized that *there was no save button*! There was no way for me save my change. I hunted around the menus, and on this forum, but didn't find anything

So I hunted around some more, and at some point, mysteriously, the save button appeared. So I clicked it. The next time I looked at my list of mailings, that mailing was *gone*. Not on the list. This was not good.

Eventually I discovered that the mailing was now in the list of templates (whew!). Somehow, it had gotten converted into a template. However, it does not seem that templates allow the same gathering of statistics as mailings do.

I think the mailing is continuing to go out -- but it was actually fairly wedged by the time this happened anyway (another story), so it's a little hard to tell.

Does anyone have any idea what happened? Is there anything I should do?

Many, many thanks for any insight you can provide!

maschoff
Site Admin
Posts: 2188
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Thu Mar 18, 2010 8:21 am

After you sent a mailing it can not be changed any longer. Therefore, the save button disappears for consistency (if it reappears later, it is a bug). You should always first copy a sent mailing and then start modifying the copied version.
OpenEMM Maintainer

nick
Posts: 7
Joined: Tue Feb 16, 2010 12:56 am

Post by nick » Thu Mar 18, 2010 5:39 pm

Thanks so very much for responding!

I was not trying to change the mailing -- I just wanted to *group* it together with some other mailings that had already been sent. Into a campaign.

Openemm changed the mailing -- by converting it into a template. It used to be on the list of mailings, but now it is on the list of templates. There is no longer a 'statistics' tab. (It was changed to be in the campaign, though.)

I will try to find out when the save button appeared; I realize it is very difficult to fix something without a real bug report!

I think the whole mailing went out, but I can no longer get statistics on click-throughs.

Again, many thanks for taking the time!

nick
Posts: 7
Joined: Tue Feb 16, 2010 12:56 am

Post by nick » Thu Mar 18, 2010 9:14 pm

I was looking around in the database, and I discovered that the broken mailing *is still in* the mailing_tbl !!!

There is a field called 'is_template', and it is 1.

Now, I would not even think of changing this without shutting down openemm and backing up the database.

But does anyone think this is likely to work? What other things might need to be changed?

Thanks!

maschoff
Site Admin
Posts: 2188
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Thu Mar 18, 2010 9:32 pm

The field is_template is the only difference between a template and a mailing. You can toggle its value to switch between mailing and template.
OpenEMM Maintainer

nick
Posts: 7
Joined: Tue Feb 16, 2010 12:56 am

Post by nick » Wed Mar 24, 2010 1:28 am

Thank you!

That seems to have worked, in that it is back to being a mailing and I can see statistics.

I'm not sure whether or not it was accumulating clickthrus or bounces while the problem still existed. The mailing was sort of at the "tail end" and there probably wern't many left anyway.

Again, many thanks!

Post Reply