Windows Intallation Help....

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

convey2web
Posts: 1
Joined: Thu Oct 28, 2010 5:52 pm

Windows Intallation Help....

Post by convey2web » Thu Oct 28, 2010 5:58 pm

Ok.. So I have followed the installation instructions up to the start.bat...

I ran "start.bat" and got the below errors...

Finally, anything that I need to do in IIS?




Starting up .. home is D:\OpenEMM .. found codebase .. found database.
Running, press return for termination: LOGFILE write failed[<type 'exceptions.IO
Error'>, (2, 'No such file or directory')]: '[28.10.2010 12:57:07] 2828 INFO/ma
in: Starting up\n'
LOGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or directory
')]: '[28.10.2010 12:57:07] 2828 FATAL/except: CAUGHT EXCEPTION:\nTraceback (mo
st recent call last):\n File "D:\\OpenEMM\\bin\\scripts\\bav-update.py", line 4
34, in <module>\n agn.lock ()\n File "D:\\OpenEMM\\bin\\scripts\\agn.py", li
ne 940, in lock\n raise error (report)\nerror: Try locking using file "C:\\Op
enEMM\\var\\lock\\bav-update.lock"\nUnable to create file: No such file or direc
tory\nUnable to create file: No such file or directory\n\n\n'
CAUGHT EXCEPTION:
Traceback (most recent call last):
File "D:\OpenEMM\bin\scripts\bav-update.py", line 434, in <module>
agn.lock ()
File "D:\OpenEMM\bin\scripts\agn.py", line 940, in lock
raise error (report)
error: Try locking using file "C:\OpenEMM\var\lock\bav-update.lock"
Unable to create file: No such file or directory
Unable to create file: No such file or directory


LOGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or directory
')]: '[28.10.2010 12:57:07] 7928 INFO/ADMIN: Initial setup for 5 threads comple
ted\n'
LOGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or directory
')]: '[28.10.2010 12:57:07] 7552 FATAL/except: CAUGHT EXCEPTION:\nTraceback (mo
st recent call last):\n File "D:\\OpenEMM\\bin\\scripts\\pickdist.py", line 189
, in <module>\n agn.lock ()\n File "D:\\OpenEMM\\bin\\scripts\\agn.py", line
940, in lock\n raise error (report)\nerror: Try locking using file "C:\\Open
EMM\\var\\lock\\pickdist.lock"\nUnable to create file: No such file or directory
\nUnable to create file: No such file or directory\n\n\n'
CAUGHT EXCEPTION:
Traceback (most recent call last):
File "D:\OpenEMM\bin\scripts\pickdist.py", line 189, in <module>
agn.lock ()
File "D:\OpenEMM\bin\scripts\agn.py", line 940, in lock
raise error (report)
error: Try locking using file "C:\OpenEMM\var\lock\pickdist.lock"
Unable to create file: No such file or directory
Unable to create file: No such file or directory


LOGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or directory
')]: '[28.10.2010 12:57:07] 7256 FATAL/except: CAUGHT EXCEPTION:\nTraceback (mo
st recent call last):\n File "D:\\OpenEMM\\bin\\scripts\\update.py", line 468,
in <module>\n agn.lock ()\n File "D:\\OpenEMM\\bin\\scripts\\agn.py", line 9
40, in lock\n raise error (report)\nerror: Try locking using file "C:\\OpenEM
M\\var\\lock\\update.lock"\nUnable to create file: No such file or directory\nUn
able to create file: No such file or directory\n\n\n'
LCOGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or director
y')]: '[28.10.2010 12:57:07] 7928 INFO/sender: Starting for ADMIN\n'
LAUGHT EXCEPTION:
Traceback (most recent call last):
File "D:\OpenEMM\bin\scripts\update.py", line 468, in <module>
agn.lock ()
File "D:\OpenEMM\bin\scripts\agn.py", line 940, in lock
raise error (report)
error: Try locking using file "C:\OpenEMM\var\lock\update.lock"
Unable to create file: No such file or directory
Unable to create file: No such file or directory


OGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or directory'
)]: '[28.10.2010 12:57:07] 7928 INFO/QUEUE: Initial setup for 50 threads comple
ted\n'
Exception in thread Spool ADMIN:
Traceback (most recent call last):
File "C:\Python27\lib\threading.py", line 530, in __bootstrap_inner
self.run()
File "D:\OpenEMM\bin\scripts\semu.py", line 670, in run
self.spool.execute ()
File "D:\OpenEMM\bin\scripts\semu.py", line 639, in execute
flist = os.listdir (self.path)
WindowsError: [Error 3] The system cannot find the path specified: 'C:\\OpenEMM\
\var\\spool\\ADMIN/*.*'

LOGFILE write failed[<type 'exceptions.IOError'>, (2, 'No such file or directory
')]: '[28.10.2010 12:57:07] 7928 INFO/sender: Starting for QUEUE\n'
Exception in thread Spool QUEUE:
Traceback (most recent call last):
File "C:\Python27\lib\threading.py", line 530, in __bootstrap_inner
self.run()
File "D:\OpenEMM\bin\scripts\semu.py", line 670, in run
self.spool.execute ()
File "D:\OpenEMM\bin\scripts\semu.py", line 639, in execute
flist = os.listdir (self.path)
WindowsError: [Error 3] The system cannot find the path specified: 'C:\\OpenEMM\
\var\\spool\\QUEUE/*.*'

Exception in thread SMTP Server:
Traceback (most recent call last):
File "C:\Python27\lib\threading.py", line 530, in __bootstrap_inner
self.run()
File "D:\OpenEMM\bin\scripts\semu.py", line 852, in run
Server.ServerLoop ()
File "D:\OpenEMM\bin\scripts\semu.py", line 802, in __init__
smtpd.SMTPServer.__init__ (self, ('0.0.0.0', port), None)
File "C:\Python27\lib\smtpd.py", line 281, in __init__
self.bind(localaddr)
File "C:\Python27\lib\asyncore.py", line 335, in bind
return self.socket.bind(addr)
File "C:\Python27\lib\socket.py", line 222, in meth
return getattr(self._sock,name)(*args)
error: [Errno 10013] An attempt was made to access a socket in a way forbidden b
y its access permissions

XAMLZealot
Posts: 1
Joined: Mon Jun 01, 2015 8:09 pm

Re: Windows Intallation Help....

Post by XAMLZealot » Mon Jun 01, 2015 8:10 pm

I am encountering this very error. Any suggestions, workarounds or solutions would be appreciated. Thanks in advance.

maschoff
Site Admin
Posts: 2225
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Windows Intallation Help....

Post by maschoff » Thu Jun 04, 2015 4:45 pm

Which version of OpenEMM do you use?
OpenEMM Maintainer

jPeterman
Posts: 11
Joined: Fri Jan 01, 2016 3:08 am
Location: Florida USA

Re: Windows Intallation Help....

Post by jPeterman » Fri Jan 01, 2016 6:15 am

I have also run into this problem. I am running OpenEmm 2015.
Did anyone figure out what a resolution to this was?

jPeterman
Posts: 11
Joined: Fri Jan 01, 2016 3:08 am
Location: Florida USA

Re: Windows Intallation Help....

Post by jPeterman » Fri Jan 01, 2016 6:19 am

Actually, this was the only error I encountered:

C:\OpenEMM>start.bat
Starting up .. home is C:\OpenEMM .. found codebase .. found database.
Running, press return for termination: Exception in thread SMTP Server:
Traceback (most recent call last):
File "C:\Python27\lib\threading.py", line 810, in __bootstrap_inner
self.run()
File "C:\OpenEMM\bin\scripts\semu.py", line 937, in run
Server.ServerLoop (self.plugin)
File "C:\OpenEMM\bin\scripts\semu.py", line 880, in __init__
smtpd.SMTPServer.__init__ (self, ('0.0.0.0', port), None)
File "C:\Python27\lib\smtpd.py", line 285, in __init__
self.bind(localaddr)
File "C:\Python27\lib\asyncore.py", line 342, in bind
return self.socket.bind(addr)
File "C:\Python27\lib\socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 10013] An attempt was made to access a socket in a way forbidden b
y its access permissions

And provided I don't hit enter, I can open the OpenEmm interface. I haven't made any attempt to send mail yet though.

jPeterman
Posts: 11
Joined: Fri Jan 01, 2016 3:08 am
Location: Florida USA

Re: Windows Intallation Help....

Post by jPeterman » Mon Jan 04, 2016 7:09 pm

SOLVED.
socket.error: [Errno 10013] an attempt was made to access a socket in a way forbidden by its access permissions.

This is caused when Python cannot connect to port 25. This could be a firewall issue or as it was in my case, because inetinfo (IIS) was already listening on that port.

I used a program called TCPview (free download) to determine that inetinfo (IIS) was already connected to SMTP.
This will cause OpenEMM to fail upon startup as it prevents Python from binding to port 25.
I went to Server Manager > Local Server > Services Window and right clicked on SMTP Service to disable it.
After that, OpenEMM started without problem.

Post Reply