Installation on Ubuntu LTS 18.04

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Firewire
Posts: 1
Joined: Tue Sep 17, 2019 12:32 pm

Installation on Ubuntu LTS 18.04

Post by Firewire » Tue Sep 17, 2019 12:54 pm

Hello.

I tried the installation of OpemEMM 2019 on Ubuntu LTS 18.04 although its not officially supported and almost got everything up running (Some minor issues could be fixed installing some missing libraries or linking to the right requested filename.), but now i have a last issue, with seems to be unresolvable on Ubuntu.

The status of openemm-Script show up, that 1 once-Script (tag-install.sh) could not finish.

Code: Select all

openemm@openemm:~/bin$ ./openemm.sh status
Status:
Using /home/openemm/bin/setenv.sh
Using additional properties: /home/openemm/tomcat9/bin/emm.sh.additional.properties
Tomcat is running as PID 11929
once        : incomplete (1 files remaining: /home/openemm/scripts/once/tag-install.sh)
mailout     : running
update      : running
trigger     : running
generate    : running
mta         : running
pickdist    : running
slrtscn     : running
direct-path : running
bav-update  : running
bavd        : running
bav         : running
mlcontrol   : running
If i manually run the script i get the following:

Code: Select all

openemm@openemm:~$ ./scripts/once/tag-install.sh
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
luatc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
I've already tried to link the library to the right filename:

Code: Select all

ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/x86_64-linux-gnu/libcrypto.so.10
but then i get:

Code: Select all

openemm@openemm:~$ ./scripts/once/tag-install.sh
luatc: /usr/lib/x86_64-linux-gnu/libcrypto.so.10: version `libcrypto.so.10' not found (required by luatc)
It seems, that luatc is compiled for the CentOS Version of libcrypto only.
I already tried to compile the backend myself to replace the luatc with the self-compiled one, but compiling failed with no noteable error.

I've come so far and would really appreciate to fix this last bit of the installation without having to switch to CentOS or Suse.

Do any of you have an idea, what could fix this?

Regards!

maschoff
Site Admin
Posts: 2206
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Installation on Ubuntu LTS 18.04

Post by maschoff » Tue Sep 17, 2019 3:44 pm

We will publish a new version of the backend source code soon that has less dependencies on external libs and compiles flawlessly with Suse. Maybe this will help with Ubuntu, too. We will announce its availability at https://twitter.com/openemm.
OpenEMM Maintainer

Post Reply