Any system requirements needed for mailing editor?

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

silversurfer
Posts: 4
Joined: Tue Apr 23, 2013 3:50 pm

Any system requirements needed for mailing editor?

Post by silversurfer » Tue Apr 23, 2013 4:29 pm

Hi there,
I already tried to find an answer in the forum and on the web, without success. I hope someone here could maybe help with my problem.

I have prepared everything to do a mailing based on a CM template, i.e. I have set up module types, content modules and a CM-Template and connected it to a mailing. I followed the instructions in the (German) manual for OpenEMM 2013.
When I edit the mailing and go to the "Contents" tab, it should (according to the manual) look like this (figure 11.22 of the manual):
Image

However, in our installation the editor capabilities are not shown, so I cannot edit, delete or move the content modules (like explained in the manual). Our screen looks like this:
Image

At the same time the "normal" html editor (e.g. when editing a "normal"= Non CM template in the tab "mailing") works without problems.

Are there any system requirements/additional installations needed to get this editor working?

Thanks

P.S.:
I've tried the following OS/Browser combinations without success:
Mac OS X 10.6.8 / Firefox
Mac OS X 10.6.8 / Safari
Win XP SP2 / Firefox
Win XP SP2 / Internet Explorer
Win XP SP2 / Chrome
Win 7 /Firefox

maschoff
Site Admin
Posts: 2261
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Any system requirements needed for mailing editor?

Post by maschoff » Tue Apr 23, 2013 7:19 pm

There are no special requirements, looks like a configuration problem to me. Check out URL properties in emm.properties and cms.properties to make sure the settings are right.
OpenEMM Maintainer

silversurfer
Posts: 4
Joined: Tue Apr 23, 2013 3:50 pm

Re: Any system requirements needed for mailing editor?

Post by silversurfer » Wed Apr 24, 2013 9:43 pm

Hi maschoff,
thanks for the reply. We have checked those propeties, but (unfortunately) everything is fine.
What wonders me even more is that the demo account on http://www.openemm.org/demo.html
also has this problem (in the teszt1 Mailing) ...?

maschoff
Site Admin
Posts: 2261
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Any system requirements needed for mailing editor?

Post by maschoff » Thu Apr 25, 2013 7:19 am

Your mail was deleted tonight (the database is truncated every night). Can you create it again so that we can reproduce your problem?
OpenEMM Maintainer

silversurfer
Posts: 4
Joined: Tue Apr 23, 2013 3:50 pm

Re: Any system requirements needed for mailing editor?

Post by silversurfer » Fri May 03, 2013 11:11 am

Hi maschoff,
sure, I just create dit again on the test account.

There is CM template called "Test CM Template", which only contains two Content Modules "Demo-Block1" and "Demo-Sailing-Footer".
"Demo-Block1" has placeholders called "Ueberschrift", "Text", "link-url" and "link-text" - "Demo-Sailing-Footer" has a placeholder "FooterText".

"Test CM Template" is assigned to the mailing called "test".

When I now go to Mailings --> Overview choose "test" and go to the content tab, there should be the possibility (thourgh icons) to delete, move or add conent modules and to insert content to the respective placeholders (like shown in the German manual on picture 11.22. and described in the respective section, point 4 and 5).

However it only looks like this (no tools) - I tried Firefox on Mac OSX and Internet Explorer on Win7:
Image

maschoff
Site Admin
Posts: 2261
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Any system requirements needed for mailing editor?

Post by maschoff » Sun May 05, 2013 4:22 pm

That was easy: You forgot to assign the two content modules to the mailing. The name of the placeholder in the CM template are generic, they do not represent names of content modules, hence there is no auto-wiring. If we would hard-link CM template placeholders to content modules it would not be possible to sort or remove them in tab content of the mailing.
OpenEMM Maintainer

silversurfer
Posts: 4
Joined: Tue Apr 23, 2013 3:50 pm

Re: Any system requirements needed for mailing editor?

Post by silversurfer » Wed May 08, 2013 6:49 pm

Thanks so much. You saved my week !

Post Reply