Throttling in v2019

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

swexpert
Posts: 3
Joined: Thu Apr 21, 2016 5:56 pm

Throttling in v2019

Post by swexpert » Sat Dec 14, 2019 4:14 pm

Hello,
First of all, Kudos to the whole team behind OpenEMM! I hope it becomes the top most EMM product and also brings in some prosperity to the team.

Now, how to do throttling in OpenEMM 2019? There is a per hour setting in "send" page but it is in fixed multiples of 1000 onwards. Additionally, the manual says it is not implemented yet in the open source version. So how to set custom speeds or something lower than 1000? In the screenshots of earlier versions, it shows "send N messages and wait for X time" option which does not appear to be available in the new version.

So in short, how to send mails lower than 1000 per hour?

Thanks
Inderjeet

maschoff
Site Admin
Posts: 2246
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Throttling in v2019

Post by maschoff » Sat Dec 14, 2019 9:12 pm

The default size for mail blocks is 1,000. The value was set when the OpenEMM DB was set up with this SQL statement:

Code: Select all

INSERT INTO config_tbl (class, name, value) VALUES ('mailout', 'ini.blocksize', '1000');
If you want to lower the blocksize (and, therefore, lower the minimum sending speed), you have to change this value.
OpenEMM Maintainer

swexpert
Posts: 3
Joined: Thu Apr 21, 2016 5:56 pm

Re: Throttling in v2019

Post by swexpert » Sun Dec 29, 2019 7:11 pm

Hello maschof,
Thanks for the prompt update. Sorry for a delayed update.
I am not sure if it is working even after changing the value in the database. Does the front-end setting "unlimited" be chosen when sending mails at this rate? After adding the line the config_table, it is still sending at 1000 mailer per hour (approximately 250 every 15 minutes).
=> Changed the value in config_table to 500
=> copied an existing mailing to a new one
=> sent test mail
=> Send mail->Shows same values, selected 1000 hoping the same will be hard-set due the db entry.
=> Mails still going at same 1000 per hour rate.
=> Changed emm.properties mailgun.ini to 500
=>Still no go. mails at 1000 per hour

Should changing the value in the database also reflect in the front-end?

Tested for 3 mailings, same result.
Please advise.

Thanks
Inderjeet

Post Reply