Ant build failed - import AgnUtils; . expected

Use this forum for all questions related to the source code of OpenEMM

Moderator: moderator

kishore
Posts: 3
Joined: Fri Oct 09, 2009 5:40 am

Ant build failed - import AgnUtils; . expected

Post by kishore » Fri Oct 09, 2009 6:00 am

Hi,

Im trying to compile openemm 5.5.1 sourcecode by ant

getting errors shown below

[javac] Compiling 297 source files to /opt/OpenEMM-5.5.1/deploy/OpenEMM/WEB-INF/classes
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/actions/ops/ExecuteScript.java:25: '.' expected
[javac] import AgnUtils;
[javac] ^
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/actions/ops/GetArchiveList.java:25: '.' expected
[javac] import AgnUtils;
[javac] ^
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/actions/ops/GetArchiveMailing.java:25: '.' expected
[javac] import AgnUtils;
[javac] ^
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/actions/ops/SendMailing.java:25: '.' expected
[javac] import AgnUtils;
[javac] ^
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/actions/ops/SubscribeCustomer.java:25: '.' expected
[javac] import AgnUtils;
[javac] ^
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/actions/ops/UpdateCustomer.java:25: '.' expected
[javac] import AgnUtils;
[javac] ^
[javac] /opt/OpenEMM-5.5.1/src/java/org/agnitas/beans/impl/AdminImpl.java:25: '.' expected
[javac] import AgnUtils;

like this it's showing same error in 98 files
Can anyone please help me in compiling the source

kishore
Posts: 3
Joined: Fri Oct 09, 2009 5:40 am

Post by kishore » Thu Oct 15, 2009 2:48 pm

Can someone help me please .....! :cry:

maschoff
Site Admin
Posts: 2146
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Sat Oct 24, 2009 10:04 am

Please have a look at the build script in the source tarball of OpenEMM 6.RC1 in the download section at SourceForge to get a better understanding of the build process of OpenEMM. We use this script ourselves to create the binary tarball out of the source tarball.
OpenEMM Maintainer

Post Reply