OpenEmm 2019 start script Bad Message

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Andrey
Posts: 15
Joined: Wed Jun 21, 2017 12:13 pm

OpenEmm 2019 start script Bad Message

Post by Andrey » Wed Jan 15, 2020 3:07 pm

Hi!
There is possibly an error in the systemd unit file openemm.service to start OpenEmm at startup.

Code: Select all

[Unit]
Description=OpenEMM startup script
After=var-run.mount network.target local-fs.target time-sync.target
sendmail.service postfix.service
[Service]
User=openemm
Group=openemm
Type=oneshot
RemainAfterExit=true
ExecStart=/home/openemm/bin/openemm.sh start
ExecStop=/home/openemm/bin/openemm.sh stop
TimeoutSec=300
StandardOutput=journal+console
[Install]
WantedBy=multi-user.target
The result is

Code: Select all

#systemctl enable openemm
#Failed to execute operation: Bad message
Please any suggestion.
OS -Centos 7

UPD:
found log messages

Code: Select all

[/etc/systemd/system/openemm.service:4] Missing '='.
[/etc/systemd/system/openemm.service:4] Missing '='.
[/etc/systemd/system/openemm.service:4] Missing '='.
[/etc/systemd/system/openemm.service:4] Missing '='.

Andrey
Posts: 15
Joined: Wed Jun 21, 2017 12:13 pm

Re: OpenEmm 2019 start script Bad Message

Post by Andrey » Wed Jan 15, 2020 3:20 pm

Found the error cause the PDF Manual auto-wrapping... this worked fine:

Code: Select all

[Unit]
Description=OpenEMM startup script
After=var-run.mount network.target local-fs.target time-sync.target sendmail.service postfix.service
[Service]
User=openemm
Group=openemm
Type=oneshot
RemainAfterExit=true
ExecStart=/home/openemm/bin/openemm.sh start
ExecStop=/home/openemm/bin/openemm.sh stop
TimeoutSec=300
StandardOutput=journal+console
[Install]
WantedBy=multi-user.target

Post Reply